aboutsummaryrefslogtreecommitdiffstats
path: root/community/git-lfs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/git-lfs/APKBUILD')
-rw-r--r--community/git-lfs/APKBUILD49
1 files changed, 21 insertions, 28 deletions
diff --git a/community/git-lfs/APKBUILD b/community/git-lfs/APKBUILD
index f6a5b8fd544..ad7bc2f1a18 100644
--- a/community/git-lfs/APKBUILD
+++ b/community/git-lfs/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=git-lfs
-pkgver=2.4.2
+pkgver=2.5.1
pkgrel=0
pkgdesc="Git extension for versioning large files"
url="https://git-lfs.github.io/"
@@ -15,10 +15,16 @@ options="!strip"
subpackages="$pkgname-doc"
install="$pkgname.post-install $pkgname.pre-deinstall"
source="$pkgname-$pkgver.tar.gz::https://github.com/git-lfs/$pkgname/archive/v$pkgver.tar.gz
- fix-test-locks.patch"
+ fix-test-locks.patch
+ makefile-extra_go_flags.patch
+ "
builddir="$srcdir/src/github.com/git-lfs/$pkgname"
export GOPATH="$srcdir:$builddir"
+# -tags netcgo - use system's DNS resolver by default. Go's built-in DNS
+# resolver is buggy; it resolved localhost to totally wrong IP
+# address on ARM builders and so caused test failures.
+_goflags="-v -tags netcgo"
prepare() {
mkdir -p "${builddir%/*}"
@@ -30,27 +36,21 @@ prepare() {
build() {
cd "$builddir"
- # Build manpages first (some embedding in the executable is done).
- cd docs
- ronn man/*.ronn
- go run man/mangen.go
- cd -
-
- # Build git-lfs executable.
- _gobuild -o bin/$pkgname
+ make \
+ EXTRA_GO_FLAGS="$_goflags" \
+ GIT_LFS_SHA="v$pkgver" \
+ VERSION="v$pkgver"
+ make man
# Build test executables.
- local file; for file in test/cmd/*.go; do
- _gobuild -o bin/$(basename $file .go) $file
+ local file; for file in t/cmd/*.go; do
+ go build $_goflags -o bin/$(basename $file .go) $file
done
- _gobuild -o bin/git-lfs-test-server-api \
- test/git-lfs-test-server-api/*.go
}
check() {
cd "$builddir"
-
- GIT_LFS_TEST_MAXPROCS=$JOBS SKIPCOMPILE=1 ./script/integration
+ make integration EXTRA_GO_FLAGS="$_goflags"
}
package() {
@@ -62,21 +62,14 @@ package() {
install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
mkdir -p "$mandir"/man1 "$mandir"/man5
- install -m 644 docs/man/*.1 "$mandir"/man1/
- install -m 644 docs/man/*.5 "$mandir"/man5/
+ install -m 644 man/*.1 "$mandir"/man1/
+ install -m 644 man/*.5 "$mandir"/man5/
mkdir -p "$docdir"
cp -r docs/*.md docs/api "$docdir"/
rm -r "$docdir"/api/schemas
}
-_gobuild() {
- # -tags netcgo - use system's DNS resolver by default. Go's built-in DNS
- # resolver is buggy; it resolved localhost to totally wrong IP
- # address on ARM builders and so caused test failures.
- # -ldflags - omit symbol and debug tables (strip).
- go build -tags netcgo -ldflags='-s -w' -v "$@"
-}
-
-sha512sums="c89a15c36b9d52091eb6e89f8e1db23b03f35333794467432ee49728ba83fc5d25d238f5df49bf736a4a3079778d70a527db01c2299ecd96a7b5f70059616967 git-lfs-2.4.2.tar.gz
-66927aa462cb7b5061442e5ffaf7c9e4a5d97179482dc00de3f4abfad5959a9c55df3e88c211067bf15b5b0ea3ef29b249ca32290cc9839280266de5c6854b3f fix-test-locks.patch"
+sha512sums="86b277795ffaba47244f3467e58c1103804f526511c4b0c21566dc05a97eb5d48d0de36f944d906255a8652b9fd698dca4dd50f89d344703b3c6d87117f7fbc1 git-lfs-2.5.1.tar.gz
+8ef31d51ef730d6fbd61e1a839b808a00cacc004b84f3d274c19c47bd2f305bc8173c770573aeb9a454b5ac3ab60947cfaac9b414c51d3bcb857f99ac8de1c41 fix-test-locks.patch
+a66cbf518f15ca59f453ba28407f848aec1f752e3052007abd2196e288a0eef5618fdb1b8ffbad3aaff01bf84efef63d268f7208345e8e6d29c90a1748dd9ffd makefile-extra_go_flags.patch"