aboutsummaryrefslogtreecommitdiffstats
path: root/community/git-lfs2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/git-lfs2/APKBUILD')
-rw-r--r--community/git-lfs2/APKBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/community/git-lfs2/APKBUILD b/community/git-lfs2/APKBUILD
index 368d370623c..a8dbf00ea07 100644
--- a/community/git-lfs2/APKBUILD
+++ b/community/git-lfs2/APKBUILD
@@ -3,19 +3,21 @@
pkgname=git-lfs2
_projname=git-lfs
pkgver=2.13.3
-pkgrel=0
+pkgrel=21
pkgdesc="Git extension for versioning large files (version 2.x)"
url="https://git-lfs.github.io/"
arch="all"
license="MIT"
depends="git !git-lfs"
makedepends="go ronn"
-checkdepends="bash coreutils git-daemon perl-utils"
+checkdepends="bash coreutils curl git-daemon perl-utils"
install="$pkgname.post-install $pkgname.pre-deinstall"
subpackages="$pkgname-doc"
source="https://github.com/git-lfs/git-lfs/archive/v$pkgver/$_projname-$pkgver.tar.gz
makefile-extra_go_flags.patch
patch-env-compare-git-grep-prefix.patch
+ fix-test-branch-name.patch
+ quote-ldflags.patch
"
builddir="$srcdir/$_projname-$pkgver"
@@ -23,13 +25,16 @@ builddir="$srcdir/$_projname-$pkgver"
# secfixes:
# 0:
-# - CVE-2020-27955 (only affect windows)
+# - CVE-2020-27955 # (only affect windows)
# -tags netcgo - use system's DNS resolver by default. Go's built-in DNS
# resolver is buggy; it resolved localhost to totally wrong IP
# address on ARM builders and so caused test failures.
-_goflags="-v -tags netcgo"
+_goflags="$GOFLAGS -v -tags netcgo"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
make \
@@ -72,4 +77,6 @@ sha512sums="
2c9e10e4f2fdb5d6bae8994db5879f50596109f3057e7369a9edca3c13c3f4d77e268e3903a0abca60cf8e342ff54bc4920c01a530f8eb400e3a0cc11a171f74 git-lfs-2.13.3.tar.gz
2d793da75b37324936407948fdb634ff4c510c4dd4d3575c2459b81a0a6eb8f2464f5066ae99e88d5bf69e357fd60354b9d9d53e062cb6ba709f5f3a39858466 makefile-extra_go_flags.patch
335ee5ef04247f8420051c75d04a59d1ebbd0cad9ec1da25ae07b5940d419c15b154f946f3c3e1fa9978201bb730f2401c5f7f606377c114fc224b8be5027d6c patch-env-compare-git-grep-prefix.patch
+74d06ddcb431b2bbbb393d01d1331c103f6b80921dd7057c347d74dc22750a1d0c051dc16a44db3cbc7dd4284b416bc561e09669701c6e29b53e0864b54543a6 fix-test-branch-name.patch
+6ca2c1d8964f616dc81e1744ebe74736ff5b70f7888eccc315e906e669f78a0d5b5cf8c5018ac14e390f778afc147ee6cbb7175504aa2f6fa4bed3c7ec663317 quote-ldflags.patch
"