aboutsummaryrefslogtreecommitdiffstats
path: root/community/git-machete/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/git-machete/APKBUILD')
-rw-r--r--community/git-machete/APKBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/community/git-machete/APKBUILD b/community/git-machete/APKBUILD
index 65d434d556d..9065dfe64e1 100644
--- a/community/git-machete/APKBUILD
+++ b/community/git-machete/APKBUILD
@@ -1,41 +1,47 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=git-machete
-pkgver=3.11.6
+pkgver=3.25.2
pkgrel=0
pkgdesc="git repository organizer & rebase/merge workflow automation tool"
url="https://github.com/VirtusLab/git-machete"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest py3-pytest-mock"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest py3-pytest-mock zsh bash fish bash-completion"
subpackages="
+ $pkgname-pyc
$pkgname-bash-completion
$pkgname-zsh-completion
$pkgname-fish-completion
"
-source="https://github.com/VirtusLab/git-machete/archive/refs/tags/v$pkgver/git-machete-$pkgver.tar.gz"
+source="https://github.com/VirtusLab/git-machete/archive/refs/tags/v$pkgver/git-machete-$pkgver.tar.gz
+ "
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ PATH="$PATH:$builddir/.testenv/bin" EDITOR=cat pytest -k 'not TestCompletionEndToEnd'
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
install -Dm0644 "$builddir"/completion/git-machete.completion.bash \
"$pkgdir/usr/share/bash-completion/completions/git-machete"
install -Dm0644 "$builddir"/completion/git-machete.completion.zsh \
"$pkgdir/usr/share/zsh/site-functions/_git-machete"
install -Dm0644 "$builddir"/completion/git-machete.fish \
- -t "$pkgdir/usr/share/fish/completions"
+ -t "$pkgdir/usr/share/fish/vendor_completions.d"
}
sha512sums="
-a49112a1d683c8ba0d6d4cafb3a22eb9f90e19a8fd469081f7b387ee43fa559d82e2c8939b51962e4136343c768c6fef1d3497ebce9891d455b3b8b472eaf058 git-machete-3.11.6.tar.gz
+0d928823d2440a46105eb8d4caa84ef828f4a01e793530151c484958b34f4209da3efa9d874dfb48a32de424cd2defc4ae3634b68e0dec7bcaf9fe82b15e68c8 git-machete-3.25.2.tar.gz
"