aboutsummaryrefslogtreecommitdiffstats
path: root/community/git-review/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/git-review/APKBUILD')
-rw-r--r--community/git-review/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/community/git-review/APKBUILD b/community/git-review/APKBUILD
index c2129c5da0e..c53d8cf577f 100644
--- a/community/git-review/APKBUILD
+++ b/community/git-review/APKBUILD
@@ -1,16 +1,17 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=git-review
-pkgver=1.28.0
-pkgrel=5
+pkgver=2.4.0
+pkgrel=0
pkgdesc="git command for submitting branches to Gerrit"
-url="https://github.com/openstack-infra/git-review"
+url="https://opendev.org/opendev/git-review"
arch="noarch"
license="Apache-2.0"
-depends="git python3 py3-requests py3-idna py3-urllib3 py3-chardet py3-certifi"
-makedepends="py3-setuptools py3-pbr"
-subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/openstack-infra/git-review/archive/$pkgver.tar.gz"
+depends="git python3 py3-requests py3-idna py3-urllib3
+py3-chardet py3-certifi py3-setuptools"
+makedepends="py3-pbr"
+subpackages="$pkgname-doc $pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/g/git-review/git-review-$pkgver.tar.gz"
build() {
python3 setup.py build
@@ -21,7 +22,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="21a71172b474ca0446f58d567e2c1b37059af3b680a3e441bcf94607d05f1fefa932ecef95328e1d77f0b71928477fd2878806ea26d2c4da030f281de15a210d git-review-1.28.0.tar.gz"
+sha512sums="
+24b8b4813933a53158eacaff8b336da1e7c948377cd147487cfccab81c7211c55f8aa8348998bfdf161b4bb9ed107aaa841b643d045498690f75fa18be0aae1f git-review-2.4.0.tar.gz
+"