aboutsummaryrefslogtreecommitdiffstats
path: root/community/git-sizer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/git-sizer/APKBUILD')
-rw-r--r--community/git-sizer/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/git-sizer/APKBUILD b/community/git-sizer/APKBUILD
index eb2ca88ca91..87c37e63aaa 100644
--- a/community/git-sizer/APKBUILD
+++ b/community/git-sizer/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=git-sizer
pkgver=1.5.0
-pkgrel=0
+pkgrel=21
pkgdesc="Compute various size metrics for a Git repository"
url="https://github.com/github/git-sizer"
license="MIT"
@@ -10,15 +10,17 @@ arch="all"
makedepends="go"
source="https://github.com/github/git-sizer/archive/v$pkgver/git-sizer-$pkgver.tar.gz
skip-test-exec.patch
+ $pkgname-fix-test-new-git.patch::https://github.com/github/git-sizer/commit/2c988fab54cadec8281786dec63c54d74bb159b9.patch
"
export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
-export GOPATH="$srcdir"
-export CGO_ENABLED=0
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build \
- -ldflags="-s -w -X main.ReleaseVersion=$pkgver" \
+ -ldflags="-X main.ReleaseVersion=$pkgver" \
-v -o bin/git-sizer
}
@@ -33,4 +35,5 @@ package() {
sha512sums="
64591c0f0b2cc35e78796ac9e4e9693453a4c1ce7d89d23d69c2d84b786586aaf63253f0d3d8e9561f0ef0c9a8ba04c67d6f066b75fb08e1f0eab51123d07d6d git-sizer-1.5.0.tar.gz
5582360e17504b418393513700e3cfe582abfe041e1213beb3760ba493badbddf9008087940651fb1efd79bf4b289050e560607f712ef67b3fc4a7e9f64e7c20 skip-test-exec.patch
+9a7be2772a60b28746e3feea55ea4981ba4fa862882de97e32afd39d604d0885a2b00085721ce56e506143d10446ed7752c2dbc4d08baeb24e60c8412b124a0a git-sizer-fix-test-new-git.patch
"