aboutsummaryrefslogtreecommitdiffstats
path: root/community/gitg/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gitg/APKBUILD')
-rw-r--r--community/gitg/APKBUILD64
1 files changed, 52 insertions, 12 deletions
diff --git a/community/gitg/APKBUILD b/community/gitg/APKBUILD
index eced37144a0..3d9f4e345b2 100644
--- a/community/gitg/APKBUILD
+++ b/community/gitg/APKBUILD
@@ -1,30 +1,70 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gitg
-pkgver=3.32.1
-pkgrel=5
+pkgver=41
+pkgrel=6
pkgdesc="gitg is the GNOME GUI client to view git repositories"
url="https://wiki.gnome.org/Apps/Gitg"
-arch="all !s390x !mips !mips64" # missing gtksourceview
+arch="all"
license="GPL-2.0-or-later"
depends="gsettings-desktop-schemas"
-makedepends="meson libsoup-dev libgee-dev glib-dev gobject-introspection-dev vala
- gsettings-desktop-schemas-dev libpeas-dev libgit2-glib-dev gtk+3.0-dev libsecret-dev
- libxml2-dev libdazzle-dev gtkspell3-dev gtksourceview-dev"
-subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.gnome.org/sources/gitg/${pkgver%.*}/gitg-$pkgver.tar.xz"
+makedepends="
+ glib-dev
+ gobject-introspection-dev
+ gsettings-desktop-schemas-dev
+ gspell-dev
+ gtk+3.0-dev
+ gtksourceview4-dev
+ json-glib-dev
+ libdazzle-dev
+ libgee-dev
+ libgit2-glib-dev
+ libpeas-dev
+ libsecret-dev
+ libxml2-dev
+ meson
+ vala
+ "
+checkdepends="bash xvfb-run"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/gitg/${pkgver%.*}/gitg-$pkgver.tar.xz
+ meson-fix-build.patch
+ "
+
+prepare() {
+ default_prepare
+
+ if want_check; then
+ # the test needs a git repository, so we make one here
+ # (we can't run this on aports since it's too large)
+ mkdir "$builddir"/tmprepo
+ cd "$builddir"/tmprepo
+ git init
+ # sometimes git fails to guess the email which would cause a failed
+ # build, this fixes it
+ git config --local user.name "test commiter"
+ git config --local user.email "test@example.com"
+ echo "test" > README.md
+ git add "README.md"
+ git commit -m "test commit"
+ fi
+}
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ cd "$builddir/tmprepo"
+ xvfb-run -a meson test --no-rebuild --print-errorlogs -C ../output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="243e630b3e5bb1919dc307e6b3fed1b1b0e3884d2a2507e4526b4af61e86f1cd7004a3dbb96001ffb0280cefe7cdb9b109c39996718913c7410224830c0145a4 gitg-3.32.1.tar.xz"
+sha512sums="
+4e8fe0b1ab5302f975f58277e5ae42300a96d20bb1c41426d8c0e058a53420fcca73f75566f593f5aa2882b3a0e1608cdd542bc4f68c731153ba9185972d6f51 gitg-41.tar.xz
+1ec57998040b1a54653c1a037a1a70d9635a9366dd796598de764954e6374385762932c5fe8ad55888b99187d5bc165effdd3a4b6922ac6e5d19ad2699f200da meson-fix-build.patch
+"