aboutsummaryrefslogtreecommitdiffstats
path: root/community/gitlab-runner/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gitlab-runner/APKBUILD')
-rw-r--r--community/gitlab-runner/APKBUILD65
1 files changed, 65 insertions, 0 deletions
diff --git a/community/gitlab-runner/APKBUILD b/community/gitlab-runner/APKBUILD
new file mode 100644
index 00000000000..bb6bb8525d5
--- /dev/null
+++ b/community/gitlab-runner/APKBUILD
@@ -0,0 +1,65 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Contributor: Rasmus Thomsen <oss@cogitir.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=gitlab-runner
+pkgver=12.1.0
+pkgrel=1
+pkgdesc="GitLab runner for CI/CD jobs"
+url="https://docs.gitlab.com/runner/"
+arch="all"
+license="MIT"
+makedepends="go"
+install="$pkgname.pre-install $pkgname.pre-upgrade"
+pkgusers="gitlab-runner"
+pkggroups="gitlab-runner"
+options="!check" # Need to be run in a git repo
+subpackages="$pkgname-helper $pkgname-openrc"
+source="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v$pkgver/gitlab-runner-v$pkgver.tar.gz
+ $pkgname.initd
+ $pkgname.confd"
+
+builddir="$srcdir/src/gitlab.com/gitlab-org/$pkgname"
+
+export GOPATH="$srcdir"
+export CGO_ENABLED=0
+
+prepare() {
+ mkdir -p ${builddir%/*}
+ mv "$srcdir"/$pkgname-v$pkgver "$builddir"/
+ default_prepare
+}
+
+build() {
+ local ldflags="
+ -X gitlab.com/gitlab-org/$pkgname/common.NAME=$pkgname
+ -X gitlab.com/gitlab-org/$pkgname/common.VERSION=$pkgver
+ -X gitlab.com/gitlab-org/$pkgname/common.REVISION=unknown
+ -X gitlab.com/gitlab-org/$pkgname/common.BUILT=$(date -u +%Y-%m-%dT%H:%M:%S%z)
+ -X gitlab.com/gitlab-org/$pkgname/common.BRANCH=unknown
+ -s -w
+ "
+ go build -ldflags "$ldflags" -o bin/gitlab-runner
+ go build -ldflags "$ldflags" -o bin/gitlab-runner-helper \
+ ./apps/gitlab-runner-helper
+}
+
+package() {
+ install -Dm755 "$builddir"/bin/gitlab-runner \
+ "$pkgdir"/usr/bin/gitlab-runner
+
+ install -m755 -D "$srcdir/$pkgname.initd" "$pkgdir"/etc/init.d/gitlab-runner
+ install -m755 -D "$srcdir/$pkgname.confd" "$pkgdir"/etc/conf.d/gitlab-runner
+
+ mkdir -p "$pkgdir"/var/lib/gitlab-runner
+ chown gitlab-runner:gitlab-runner "$pkgdir"/var/lib/gitlab-runner
+}
+
+helper() {
+ pkgdesc="$pkgdesc (helper)"
+ install -Dm755 "$builddir"/bin/gitlab-runner-helper \
+ "$subpkgdir"/usr/bin/gitlab-runner-helper
+}
+
+sha512sums="1b3f06b7000252631bec04a58474dda826b0fb8d28c4144051a231fba5ef0c5c4b6e0f9ca6bdf9bf9b16b9117cbcf6385eb7bac85bda7b9f99de4300cbcc2066 gitlab-runner-v12.1.0.tar.gz
+2ae753efc220c46378e84831f01b289f3689af70cd7cbb0bbcc04dc17c910d65eb5105c198d5a23098e27797a7d1c695f49b244993ea4676eb9ec9cda064f44e gitlab-runner.initd
+243ed9d7575e925794213973232f95f02d5e10cfab6cd29df6a4641b9d05b342ae90678b2eea4b21ddc703596429919d037b38248046d7c5e7a480406f412445 gitlab-runner.confd"