aboutsummaryrefslogtreecommitdiffstats
path: root/community/gitstatus/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gitstatus/APKBUILD')
-rw-r--r--community/gitstatus/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/community/gitstatus/APKBUILD b/community/gitstatus/APKBUILD
index 7972c924fcf..3e5bcfb5fb8 100644
--- a/community/gitstatus/APKBUILD
+++ b/community/gitstatus/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=gitstatus
-pkgver=1.5.4
+pkgver=1.5.5
pkgrel=0
pkgdesc="Git status for Bash and Zsh prompt"
url="https://github.com/romkatv/gitstatus"
@@ -10,7 +10,8 @@ license="GPL-3.0-or-later"
makedepends="
cmake
http-parser-dev
- pcre-dev
+ pcre2-dev
+ samurai
zlib-dev
zsh
"
@@ -22,10 +23,11 @@ subpackages="
# IMPORTANT: Keep in sync with $libgit2_version in build.info file.
# NOTE: The upstream maintains a fork of libgit2 with patches specific for
# gitstatus, it cannot be built with vanilla libgit2.
-_libgit2_ver="tag-0ad3d776aa86dd607dc86dcd7f77ad3ed7ebec61"
+_libgit2_ver="tag-2ecf33948a4df9ef45a66c68b8ef24a5e60eaac6"
source="https://github.com/romkatv/gitstatus/archive/v$pkgver/gitstatus-$pkgver.tar.gz
https://github.com/romkatv/libgit2/archive/$_libgit2_ver/libgit2-$_libgit2_ver.tar.gz
make-ldlibs.patch
+ dirent64.patch
install
"
@@ -51,10 +53,9 @@ prepare() {
# and instead replicate it here with some changes.
build() {
# Flags copied from gitstatus' build script (except -flto).
- local common_cflags="-fno-plt -Wformat -Werror=format-security -fstack-clash-protection -flto"
+ local common_cflags="-fno-plt -Wformat -Werror=format-security -fstack-clash-protection -flto=auto"
export CFLAGS="${CFLAGS/-Os/-O2} $common_cflags"
- export LDFLAGS="$LDFLAGS -flto"
cd deps/libgit2
@@ -63,7 +64,7 @@ build() {
# 1st group of flags is copied from the gitstatus' build script.
# 2nd group is also present in the build script, but they were changed
# in favour of shared dependencies.
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DZERO_NSEC=ON \
-DTHREADSAFE=ON \
@@ -76,7 +77,7 @@ build() {
-DENABLE_REPRODUCIBLE_BUILDS=ON \
\
-DUSE_BUNDLED_ZLIB=OFF \
- -DREGEX_BACKEND=pcre \
+ -DREGEX_BACKEND=pcre2 \
-DUSE_HTTP_PARSER=system \
\
-DCMAKE_VERBOSE_MAKEFILE=ON
@@ -91,7 +92,7 @@ build() {
CXXFLAGS="${CXXFLAGS/-Os/-O2} $common_cflags -Ideps/libgit2/include \
-DGITSTATUS_ZERO_NSEC -D_GNU_SOURCE -D_GLIBCXX_ASSERTIONS" \
LDFLAGS="$LDFLAGS -Ldeps/libgit2/build" \
- LDLIBS="-lz -lpcre -lhttp_parser" \
+ LDLIBS="-lz -lpcre2-8 -lhttp_parser" \
make
# Compile Zsh scripts.
@@ -152,8 +153,9 @@ _zsh_plugin() {
}
sha512sums="
-db7b082f302851e516c79fb464972fc065aafae426dc1d732b2a08e72d88e47a35b11c079cd7bb8795b8363dc8a583c1c62bb44566d82e5c925a335c015c0329 gitstatus-1.5.4.tar.gz
-ffd637fc9e8ed440953f5fc39ca736785ff961f6391bff541dee3fe4e89b3d9eb44ef54767963eb63a14c314c7e53538e00e1ad7d83090d03eead40f160045a5 libgit2-tag-0ad3d776aa86dd607dc86dcd7f77ad3ed7ebec61.tar.gz
+8fa4fe941128427f5362d97620bbf5b2722682843197649b3acae4e9ccffcb694226510b2957c65b6b68c27e5518a3b6aa841b624cff160e48d8c8014e0f6757 gitstatus-1.5.5.tar.gz
+f3d056eb181ec084ebe3d5bcd6edaddb781a22eeac747115cb4fb09015904ccae9b439145430bfe6fd544e39fe3f019e3512e1010549d53cc8338039ec339f9c libgit2-tag-2ecf33948a4df9ef45a66c68b8ef24a5e60eaac6.tar.gz
862b94977c117419c94a287e1f854fe027a8011667b27160229baf369d5c545e29356093e82bdfd53d94dff1f62fbf19ff1f612d1f4cbccde09dbd5221c26243 make-ldlibs.patch
+65659fd901162ecd0eab63c1c37cc0fc6f39fa58adcf2998df4410e1589e82248b8e6ead5cdb2b21d12150183894afe3a4506519a4dcffcc414c55ef4709f718 dirent64.patch
565991bbe55e1538f9ac5ecb77d0dc9edc2e6fb4376555b3bb09a7b5dceb63c1df85526ff993994b6026e30424f710f3673e248d85c66cb234fd5493db0e98f2 install
"