aboutsummaryrefslogtreecommitdiffstats
path: root/community/gjs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gjs/APKBUILD')
-rw-r--r--community/gjs/APKBUILD71
1 files changed, 58 insertions, 13 deletions
diff --git a/community/gjs/APKBUILD b/community/gjs/APKBUILD
index 9326d8071a3..855099cbace 100644
--- a/community/gjs/APKBUILD
+++ b/community/gjs/APKBUILD
@@ -1,31 +1,75 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gjs
-pkgver=1.72.0
-pkgrel=0
+# even number after first dot are the stable releases
+pkgver=1.80.2
+pkgrel=1
pkgdesc="GNOME javascript library"
url="https://wiki.gnome.org/Projects/Gjs"
-# s390x and riscv64 blocked by mozjs91
-arch="all !s390x !riscv64"
+# armhf and s390x blocked by mozjs102
+arch="all !armhf !s390x"
license="MIT AND LGPL-2.0-or-later"
-makedepends="dbus gobject-introspection-dev mozjs91-dev mozjs91
- gtk+3.0-dev cairo-dev meson libffi>=3.3"
+makedepends="
+ cairo-dev
+ clang
+ dbus
+ gobject-introspection-dev
+ gtk+3.0-dev
+ libffi>=3.3
+ meson
+ mozjs115-dev
+ "
checkdepends="xvfb-run"
-subpackages="$pkgname-dev"
-options="!check" # test suite does not always pass on all architectures
-source="https://download.gnome.org/sources/gjs/${pkgver%.*}/gjs-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-dbg"
+source="https://download.gnome.org/sources/gjs/${pkgver%.*}/gjs-$pkgver.tar.xz
+ encoding.patch
+ "
+
+case "$CARCH" in
+riscv64)
+ # lld broken on riscv64
+ ;;
+*)
+ makedepends="$makedepends lld"
+ ;;
+esac
build() {
+ case "$CARCH" in
+ aarch64|arm*|riscv64)
+ # not supported by clang here
+ export CFLAGS="${CFLAGS/-fstack-clash-protection}"
+ export CXXFLAGS="${CXXFLAGS/-fstack-clash-protection}"
+ ;;
+ esac
+
+ case "$CARCH" in
+ riscv64)
+ local lto=false
+ ;;
+ *)
+ local lto=true
+ export LDFLAGS="$LDFLAGS -fuse-ld=lld"
+ ;;
+ esac
+
+ CC=clang \
+ CXX=clang++ \
+ CFLAGS="$CFLAGS -O2" \
+ CXXFLAGS="$CXXFLAGS -O2" \
abuild-meson \
+ --buildtype=release \
+ -Db_lto=$lto \
+ -Db_ndebug=true \
-Dprofiler=disabled \
-Dinstalled_tests=false \
output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
# Tests can take a while on armv7
- xvfb-run meson test -C output -t 10
+ xvfb-run -a meson test --print-errorlogs --no-rebuild -C output -t 10
}
package() {
@@ -33,5 +77,6 @@ package() {
}
sha512sums="
-224934eed511052d013cc7c2a29ccf79b14e5ed8c01db8071f07858387d7794b9156abd43ac494a13294248d9b6f2956d21c4e9581a41f5161043dff374f72f9 gjs-1.72.0.tar.xz
+cc9a9073f741ee60eff2d2ce808cca7f40e97798f9ffa9197ebc3780a8a5df6e174ba76293bf7547fc8fa7e82be6a828a633a5aa8ba27d551dec72d635b6c5bd gjs-1.80.2.tar.xz
+3524a4c6772f1be1d6e2320650d7fb9f81cc2ceb7c79c2521c0ee7a4202d5681a88586ab9439050611ee1719f9a977bb65d0eaaa536148e7e4590baf1f50eae8 encoding.patch
"