aboutsummaryrefslogtreecommitdiffstats
path: root/community/gjs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gjs/APKBUILD')
-rw-r--r--community/gjs/APKBUILD71
1 files changed, 60 insertions, 11 deletions
diff --git a/community/gjs/APKBUILD b/community/gjs/APKBUILD
index 6b6f801e7e6..855099cbace 100644
--- a/community/gjs/APKBUILD
+++ b/community/gjs/APKBUILD
@@ -1,33 +1,82 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gjs
-pkgver=1.66.2
-pkgrel=0
+# even number after first dot are the stable releases
+pkgver=1.80.2
+pkgrel=1
pkgdesc="GNOME javascript library"
url="https://wiki.gnome.org/Projects/Gjs"
-arch="all !s390x !mips !mips64"
+# armhf and s390x blocked by mozjs102
+arch="all !armhf !s390x"
license="MIT AND LGPL-2.0-or-later"
-makedepends="dbus gobject-introspection-dev mozjs78-dev mozjs78
- gtk+3.0-dev cairo-dev meson libffi>=3.3"
+makedepends="
+ cairo-dev
+ clang
+ dbus
+ gobject-introspection-dev
+ gtk+3.0-dev
+ libffi>=3.3
+ meson
+ mozjs115-dev
+ "
checkdepends="xvfb-run"
-subpackages="$pkgname-dev"
-source="https://download.gnome.org/sources/gjs/${pkgver%.*}/gjs-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-dbg"
+source="https://download.gnome.org/sources/gjs/${pkgver%.*}/gjs-$pkgver.tar.xz
+ encoding.patch
+ "
+
+case "$CARCH" in
+riscv64)
+ # lld broken on riscv64
+ ;;
+*)
+ makedepends="$makedepends lld"
+ ;;
+esac
build() {
+ case "$CARCH" in
+ aarch64|arm*|riscv64)
+ # not supported by clang here
+ export CFLAGS="${CFLAGS/-fstack-clash-protection}"
+ export CXXFLAGS="${CXXFLAGS/-fstack-clash-protection}"
+ ;;
+ esac
+
+ case "$CARCH" in
+ riscv64)
+ local lto=false
+ ;;
+ *)
+ local lto=true
+ export LDFLAGS="$LDFLAGS -fuse-ld=lld"
+ ;;
+ esac
+
+ CC=clang \
+ CXX=clang++ \
+ CFLAGS="$CFLAGS -O2" \
+ CXXFLAGS="$CXXFLAGS -O2" \
abuild-meson \
+ --buildtype=release \
+ -Db_lto=$lto \
+ -Db_ndebug=true \
-Dprofiler=disabled \
-Dinstalled_tests=false \
output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
# Tests can take a while on armv7
- xvfb-run meson test -C output -t 10
+ xvfb-run -a meson test --print-errorlogs --no-rebuild -C output -t 10
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="2e0ca24532b3203a55089eb25de19b4b4f33166f40d1231198947057e45f364d3c7f794ff2079c1d9aee3fde9f99cd844944229d89d5e344a97254aaa42bad40 gjs-1.66.2.tar.xz"
+sha512sums="
+cc9a9073f741ee60eff2d2ce808cca7f40e97798f9ffa9197ebc3780a8a5df6e174ba76293bf7547fc8fa7e82be6a828a633a5aa8ba27d551dec72d635b6c5bd gjs-1.80.2.tar.xz
+3524a4c6772f1be1d6e2320650d7fb9f81cc2ceb7c79c2521c0ee7a4202d5681a88586ab9439050611ee1719f9a977bb65d0eaaa536148e7e4590baf1f50eae8 encoding.patch
+"