aboutsummaryrefslogtreecommitdiffstats
path: root/community/glab/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/glab/APKBUILD')
-rw-r--r--community/glab/APKBUILD34
1 files changed, 23 insertions, 11 deletions
diff --git a/community/glab/APKBUILD b/community/glab/APKBUILD
index 28446904fbd..619805ec665 100644
--- a/community/glab/APKBUILD
+++ b/community/glab/APKBUILD
@@ -1,26 +1,37 @@
# Contributor: solidnerd <niclas@mietz.io>
-# Maintainer: solidnerd <niclas@mietz.io>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=glab
-pkgver=1.22.0
-pkgrel=3
+pkgver=1.37.0
+pkgrel=1
pkgdesc="Open source GitLab CLI tool written in Go"
-url="https://github.com/profclems/glab"
+url="https://gitlab.com/gitlab-org/cli"
arch="all"
license="MIT"
depends="git"
makedepends="go"
-options="!check chmod-clean" # Need to be run in a git repo
+options="!check"
subpackages="
$pkgname-bash-completion
$pkgname-zsh-completion
$pkgname-fish-completion
"
-source="$pkgname-$pkgver.tar.gz::https://github.com/profclems/glab/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.com/gitlab-org/cli/-/archive/v$pkgver/cli-v$pkgver.tar.gz"
+builddir="$srcdir/cli-v$pkgver"
-export CGO_ENABLED=0
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- make build GLAB_VERSION=$pkgver
+ # date seems a little broken to override
+ go build -ldflags "
+ -X main.debugMode=false
+ -X main.version=v$pkgver
+ -X main.buildDate=$(date -u "+%Y-%m-%d" ${SOURCE_DATE_EPOCH:+-d @$SOURCE_DATE_EPOCH})
+ -extldflags \"$LDFLAGS\"
+ " \
+ -o bin/glab \
+ ./cmd/glab/main.go
# XXX: When glab is run in fakeroot it segfaults for some reason
# on ppc64le. By generating the compilation files here we
@@ -32,12 +43,13 @@ build() {
}
package() {
- install -Dm755 "$builddir"/bin/glab -t "$pkgdir"/usr/bin/
+ install -Dm755 bin/glab -t "$pkgdir"/usr/bin/
install -Dm644 bash.comp "$pkgdir"/usr/share/bash-completion/completions/glab.bash
install -Dm644 zsh.comp "$pkgdir"/usr/share/zsh/site-functions/_glab
- install -Dm644 fish.comp "$pkgdir"/usr/share/fish/completions/glab.fish
+ install -Dm644 fish.comp "$pkgdir"/usr/share/fish/vendor_completions.d/glab.fish
}
+
sha512sums="
-1948e9c330c31240fcfa5fdcae597b4ae11b1df2d3d5d85a095913988a8f5483107202ce66a474c081cc4b8a44cc5b317dc1f65f75f6b0c3e11308e2bb2b91b5 glab-1.22.0.tar.gz
+9988983864540f63648c98f67dcd4cb32512f8711996e8e213d4cd8b0fd2cf5b3fc9d25a027841cfe01ecdf5c785bfb998cb90ff5a1b08d713b7476f443aaec6 glab-1.37.0.tar.gz
"