aboutsummaryrefslogtreecommitdiffstats
path: root/community/glacier-gallery/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/glacier-gallery/APKBUILD')
-rw-r--r--community/glacier-gallery/APKBUILD45
1 files changed, 0 insertions, 45 deletions
diff --git a/community/glacier-gallery/APKBUILD b/community/glacier-gallery/APKBUILD
deleted file mode 100644
index 4e03d47f24c..00000000000
--- a/community/glacier-gallery/APKBUILD
+++ /dev/null
@@ -1,45 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=glacier-gallery
-pkgver=0.2.3_git20211002
-pkgrel=1
-_commit="839e54ff08e0c895775f4aaae7d93487fcb13dbf"
-pkgdesc="The Glacier image gallery"
-url="https://github.com/nemomobile-ux/glacier-gallery"
-# armhf blocked by qtquickcontrols-nemo
-arch="all !armhf"
-license="BSD-3-Clause"
-depends="
- mapplauncherd
- nemo-qml-plugin-thumbnailer
- qt5-qtdocgallery
- qtquickcontrols-nemo
- "
-makedepends="
- cmake
- libglacierapp-dev
- libresourceqt-dev
- qt5-qtbase-dev
- qt5-qttools-dev
- samurai
- "
-source="https://github.com/nemomobile-ux/glacier-gallery/archive/$_commit/glacier-gallery-$_commit.tar.gz"
-options="!check" # No tests
-builddir="$srcdir/$pkgname-$_commit"
-
-build() {
- cmake -B build -G Ninja \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DINSTALL_QML_IMPORT_DIR=/usr/lib/qt5/qml
- cmake --build build
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
-}
-
-sha512sums="
-079306c0a45945b8f3fa019fde7286923d253f59e42ac812debc4be33154cc7cd40de46ec19c199f441078d534c03d5b8dfef1689d96d7206cbeed2358bba76c glacier-gallery-839e54ff08e0c895775f4aaae7d93487fcb13dbf.tar.gz
-"