aboutsummaryrefslogtreecommitdiffstats
path: root/community/glade/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/glade/APKBUILD')
-rw-r--r--community/glade/APKBUILD62
1 files changed, 47 insertions, 15 deletions
diff --git a/community/glade/APKBUILD b/community/glade/APKBUILD
index fd6019a9846..74c03ab341a 100644
--- a/community/glade/APKBUILD
+++ b/community/glade/APKBUILD
@@ -1,34 +1,61 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=glade
-pkgver=3.38.2
-pkgrel=0
+pkgver=3.40.0
+pkgrel=6
pkgdesc="User Interface Designer for GTK+ and GNOME"
url="https://glade.gnome.org/"
-arch="all !mips64" # blocked by webkit2gtk
+arch="all"
license="GPL-2.0-or-later"
-makedepends="gtk+3.0-dev libxml2-dev itstool gtk-doc intltool
- webkit2gtk-dev py3-gobject3-dev gobject-introspection-dev meson
- python3-dev"
-checkdepends="xvfb-run ibus adwaita-icon-theme"
-options="!check" # If adwaita-icon-theme wasn't installed e before we'd have to updathe the icon cache
+makedepends="
+ gobject-introspection-dev
+ gtk+3.0-dev
+ gtk-doc
+ itstool
+ libxml2-dev
+ meson
+ py3-gobject3-dev
+ python3-dev
+ webkit2gtk-4.1-dev
+ "
+checkdepends="
+ adwaita-icon-theme
+ dbus
+ ibus
+ xvfb-run
+ "
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://download.gnome.org/sources/glade/${pkgver%.*}/glade-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/glade/${pkgver%.*}/glade-$pkgver.tar.xz
+ webkit2gtk-4.1.patch
+ "
+# XXX: segfault in mozjs102, but it runs fine..
+options="!check"
case "$CARCH" in
- s390x|mips*) ;;
- *) makedepends="$makedepends gjs-dev" ;;
+armhf|s390x|riscv64)
+ ;;
+*)
+ makedepends="$makedepends gjs-dev"
+ ;;
esac
+if [ "$CARCH" = "s390x" ]; then
+ # no adwaita-icon-theme
+ options="$options !check"
+fi
+
build() {
abuild-meson \
-Dgladeui=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- xvfb-run meson test --no-rebuild -v -C output
+ XDG_RUNTIME_DIR="$(mktemp -d -p "$builddir")" \
+ dbus-run-session -- \
+ xvfb-run -a \
+ meson test -t 6 --no-rebuild --print-errorlogs -C output
}
package() {
@@ -37,8 +64,13 @@ package() {
dev() {
default_dev
+
mkdir -p "$pkgdir"/usr/share/glade
mv "$subpkgdir"/usr/share/glade/catalogs "$pkgdir"/usr/share/glade
+ mv "$subpkgdir"/usr/lib/glade "$pkgdir"/usr/lib/glade
}
-sha512sums="2df8c8363206905663cd3ac9196da44445425a888b64f1b3b3ac6cd41e14c4a82a5d2c299730ef0606c3970a04dd8f245bb5639218794eb67dcbd26fae17565e glade-3.38.2.tar.xz"
+sha512sums="
+6b018f882e9d155a4b2256c0b4c72743f971c8d730a53f16faa240d01e14051f5b6ce04e355dcc78e1679579fb091facaa06acdda6297c5b8efc642c42bb7b4e glade-3.40.0.tar.xz
+9ce098990c38cf2c9b2b0ec98d3e0925ebf5d2b993240f5ae2a0a4f2c3f027625a32d694f8626f7ede693caa60ecd55abd75e93e0cb60fe0bd0637ae170f85d9 webkit2gtk-4.1.patch
+"