aboutsummaryrefslogtreecommitdiffstats
path: root/community/glibd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/glibd/APKBUILD')
-rw-r--r--community/glibd/APKBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/community/glibd/APKBUILD b/community/glibd/APKBUILD
index ce18150a7e4..4a4c5acf145 100644
--- a/community/glibd/APKBUILD
+++ b/community/glibd/APKBUILD
@@ -1,26 +1,25 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=glibd
-pkgver=2.3.0
-pkgrel=0
+pkgver=2.4.2
+pkgrel=4
pkgdesc="D bindings for the GLib C Utility Library"
url="https://github.com/gtkd-developers/GlibD"
arch="x86_64 aarch64" # ldc
license="GPL-3.0-or-later"
-makedepends="meson gobject-introspection-dev glib-dev ldc ldc-runtime gir-to-d"
+makedepends="meson gobject-introspection-dev glib-dev ldc gir-to-d"
subpackages="$pkgname-dev $pkgname-dbg"
source="https://github.com/gtkd-developers/GlibD/archive/v$pkgver/glibd-$pkgver.tar.gz
- fix-sonames.patch
- glib-2.68.patch"
+ Trivial-fix-for-Glib-2.78.patch"
builddir="$srcdir/GlibD-$pkgver"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -28,7 +27,6 @@ package() {
}
sha512sums="
-3312eb81f6a586be4755942c23f46b23144c7ca5239a187eb30917f8e1c6726a63ecdfbe408276502f688f39dfb0f281248905a88692ec7d79875af53f893455 glibd-2.3.0.tar.gz
-d97413d6615788f456eaa762e0f384ac9f3a1739d669013cf07631719783b24b4db89cdbb9f8b58bb4e49ce71a7783cf3f0cd9f9bd2879aa739d140b9b0d1c40 fix-sonames.patch
-39e4eaba9fe01ae072e9c179b3e132bd241c94339ca31a47e64cda460aa9cd2ba2b59c8c25e0fb095386b10d83a033b1860afe8ca82e4a2076934a96a4a94012 glib-2.68.patch
+6db52b29cf90a5d8f6ddb43c1ddcd5bcc6ed5b2b6cd575711beffff74b8592c07aa3c6a1047954305cbcd515ef6ea814c162a91c12e9580d5938228ecc7a6d49 glibd-2.4.2.tar.gz
+7bcbf68b9a069860e81232da4ece4ea3e8f766afcefbb6dcff060e897bdd6dc00c8f045eb5b1547a981b08990b678eb54f22d620e375f1ee469caeb09331e2f7 Trivial-fix-for-Glib-2.78.patch
"