aboutsummaryrefslogtreecommitdiffstats
path: root/community/glibmm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/glibmm/APKBUILD')
-rw-r--r--community/glibmm/APKBUILD27
1 files changed, 12 insertions, 15 deletions
diff --git a/community/glibmm/APKBUILD b/community/glibmm/APKBUILD
index 4be7e286f9c..3f3f782477b 100644
--- a/community/glibmm/APKBUILD
+++ b/community/glibmm/APKBUILD
@@ -1,20 +1,24 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=glibmm
-pkgver=2.66.2
+pkgver=2.66.7
pkgrel=0
pkgdesc="C++ wrapper for the GLib toolkit"
url="https://www.gtkmm.org/"
arch="all"
license="LGPL-2.1-or-later"
-makedepends="glib-dev libsigc++-dev perl meson m4 doxygen graphviz"
-subpackages="$pkgname-dev $pkgname-doc"
+makedepends="glib-dev libsigc++-dev perl meson m4"
+subpackages="$pkgname-dev"
source="https://download.gnome.org/sources/glibmm/${pkgver%.*}/glibmm-$pkgver.tar.xz"
build() {
- abuild-meson -Dbuild-documentation=true . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson \
+ -Db_lto=true \
+ -Dbuild-documentation=false \
+ -Dbuild-examples=false \
+ . output
+ meson compile -C output
}
package() {
@@ -22,17 +26,10 @@ package() {
}
dev() {
- mkdir -p "$subpkgdir"/usr/lib/
- mv "$pkgdir"/usr/lib/glibmm-2.4 "$subpkgdir"/usr/lib/
+ amove usr/lib/glibmm-*
default_dev
}
-doc() {
- default_doc
- mkdir -p "$subpkgdir"/usr/share/
- mv "$pkgdir"/usr/share/devhelp "$subpkgdir"/usr/share/
-}
-
sha512sums="
-097af6b140a5af3e52cc2c5d251475a5aa923d0c528c3cbc97f31d3a95868bcb3aa2328047ca94a55ef7fd188f271917dfe29faa86f477a441f0a024284216f9 glibmm-2.66.2.tar.xz
+09b99622c051afd264d7a9b23025ee28ec870c6d23a5084ef7192f67b96fb8f16be5dbb2e8a4ff8a1d4ff873d3e73b4e25dee122049266687f471dcd3989b5bb glibmm-2.66.7.tar.xz
"