aboutsummaryrefslogtreecommitdiffstats
path: root/community/glibmm2.68/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/glibmm2.68/APKBUILD')
-rw-r--r--community/glibmm2.68/APKBUILD36
1 files changed, 15 insertions, 21 deletions
diff --git a/community/glibmm2.68/APKBUILD b/community/glibmm2.68/APKBUILD
index 40282d4fff6..d7399c2d599 100644
--- a/community/glibmm2.68/APKBUILD
+++ b/community/glibmm2.68/APKBUILD
@@ -1,22 +1,25 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=glibmm2.68
-pkgver=2.72.1
-pkgrel=0
+pkgver=2.78.0
+pkgrel=1
pkgdesc="C++ wrapper for the GLib toolkit"
url="https://www.gtkmm.org/"
arch="all"
license="LGPL-2.1-or-later"
-makedepends="glib-dev libsigc++3-dev perl meson m4 doxygen graphviz"
-checkdepends="glib-networking libsoup"
-subpackages="$pkgname-dev $pkgname-doc"
+makedepends="glib-dev libsigc++3-dev perl meson m4"
+checkdepends="glib-networking"
+subpackages="$pkgname-dev"
source="https://download.gnome.org/sources/glibmm/${pkgver%.*}/glibmm-$pkgver.tar.xz"
builddir="$srcdir/glibmm-$pkgver"
build() {
- abuild-meson -Dbuild-documentation=true . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson \
+ -Db_lto=true \
+ -Dbuild-documentation=false \
+ -Dbuild-examples=false \
+ . output
+ meson compile -C output
}
package() {
@@ -24,23 +27,14 @@ package() {
}
dev() {
- mkdir -p "$subpkgdir"/usr/lib/
- mv "$pkgdir"/usr/lib/glibmm-${pkgname/glibmm} \
- "$pkgdir"/usr/lib/giomm-${pkgname/glibmm} \
- "$subpkgdir"/usr/lib/
+ amove usr/lib/glibmm-* usr/lib/giomm-*
default_dev
}
check() {
- meson test --no-rebuild -v -C output
-}
-
-doc() {
- default_doc
- mkdir -p "$subpkgdir"/usr/share/
- mv "$pkgdir"/usr/share/devhelp "$subpkgdir"/usr/share/
+ meson test --no-rebuild --print-errorlogs -C output
}
sha512sums="
-aa52c7b73e8f3437c2da9e8da74f84b9f07c7aa40a5fa232a7418b4af19575cbde01f6cbe9fb3fc3227bd9281a9439156a51d10a0c2c1a1beca226c7c93fe660 glibmm-2.72.1.tar.xz
+b93575983860101d793725e08c13987914465e4daf280defb4a96b2f842b9e1a99c9320b05f2a6af9e3f7a2a384855b6710b982f9015a6469e37f3c257d9d811 glibmm-2.78.0.tar.xz
"