aboutsummaryrefslogtreecommitdiffstats
path: root/community/glibmm2.68/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/glibmm2.68/APKBUILD')
-rw-r--r--community/glibmm2.68/APKBUILD38
1 files changed, 17 insertions, 21 deletions
diff --git a/community/glibmm2.68/APKBUILD b/community/glibmm2.68/APKBUILD
index e0ef211b656..d7399c2d599 100644
--- a/community/glibmm2.68/APKBUILD
+++ b/community/glibmm2.68/APKBUILD
@@ -1,22 +1,25 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=glibmm2.68
-pkgver=2.68.1
-pkgrel=0
+pkgver=2.78.0
+pkgrel=1
pkgdesc="C++ wrapper for the GLib toolkit"
url="https://www.gtkmm.org/"
arch="all"
license="LGPL-2.1-or-later"
-makedepends="glib-dev libsigc++3-dev perl meson m4 doxygen graphviz"
-checkdepends="glib-networking libsoup"
-subpackages="$pkgname-dev $pkgname-doc"
+makedepends="glib-dev libsigc++3-dev perl meson m4"
+checkdepends="glib-networking"
+subpackages="$pkgname-dev"
source="https://download.gnome.org/sources/glibmm/${pkgver%.*}/glibmm-$pkgver.tar.xz"
builddir="$srcdir/glibmm-$pkgver"
build() {
- abuild-meson -Dbuild-documentation=true . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson \
+ -Db_lto=true \
+ -Dbuild-documentation=false \
+ -Dbuild-examples=false \
+ . output
+ meson compile -C output
}
package() {
@@ -24,21 +27,14 @@ package() {
}
dev() {
- mkdir -p "$subpkgdir"/usr/lib/
- mv "$pkgdir"/usr/lib/glibmm-${pkgver%.*} \
- "$pkgdir"/usr/lib/giomm-${pkgver%.*} \
- "$subpkgdir"/usr/lib/
+ amove usr/lib/glibmm-* usr/lib/giomm-*
default_dev
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
-doc() {
- default_doc
- mkdir -p "$subpkgdir"/usr/share/
- mv "$pkgdir"/usr/share/devhelp "$subpkgdir"/usr/share/
-}
-
-sha512sums="ca164f986da651e66bb5b98a760853e73d57ff84e035809d4c3b2c0a1b6ddf8ca68ffc49a71d0e0b2e14eca1c00e2e727e3bf3821e0b2b3a808397c3d33c6d5c glibmm-2.68.1.tar.xz"
+sha512sums="
+b93575983860101d793725e08c13987914465e4daf280defb4a96b2f842b9e1a99c9320b05f2a6af9e3f7a2a384855b6710b982f9015a6469e37f3c257d9d811 glibmm-2.78.0.tar.xz
+"