aboutsummaryrefslogtreecommitdiffstats
path: root/community/gmnitohtml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gmnitohtml/APKBUILD')
-rw-r--r--community/gmnitohtml/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/gmnitohtml/APKBUILD b/community/gmnitohtml/APKBUILD
new file mode 100644
index 00000000000..9863f34fecb
--- /dev/null
+++ b/community/gmnitohtml/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Willow Barraco <contact@willowbarraco.fr>
+pkgname=gmnitohtml
+pkgver=0.1.2
+pkgrel=8
+pkgdesc="Gemini text to HTML converter"
+options="!check" # No testsuite
+url="https://git.sr.ht/~adnano/gmnitohtml"
+arch="all"
+license="GPL-3.0-only"
+makedepends="go scdoc"
+subpackages="$pkgname-doc"
+source="
+ $pkgname-$pkgver.tar.gz::https://git.sr.ht/~adnano/gmnitohtml/archive/$pkgver.tar.gz
+ "
+options="$options net" # fetch dependencies
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+build() {
+ make GOFLAGS="$GOFLAGS --tags=extended"
+}
+
+package() {
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+sha512sums="
+542fc2da6734661bb35f518e0815f71beacdd91a70153da0b22372aa1841475ebec907d945d14c35e8e0e4c0074a16ef0f041c61c6a3d0c63cb69d13b3ddf347 gmnitohtml-0.1.2.tar.gz
+"