aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-2048/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-2048/APKBUILD')
-rw-r--r--community/gnome-2048/APKBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/community/gnome-2048/APKBUILD b/community/gnome-2048/APKBUILD
index 6b4ce25c77c..a2da0660fe6 100644
--- a/community/gnome-2048/APKBUILD
+++ b/community/gnome-2048/APKBUILD
@@ -1,29 +1,34 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-2048
pkgver=3.38.2
-pkgrel=1
-arch="all"
-url="https://wiki.gnome.org/Apps/2048"
+pkgrel=3
pkgdesc="Obtain the 2048 tile"
+url="https://wiki.gnome.org/Apps/2048"
license="GPL-3.0-or-later"
+arch="all"
makedepends="meson ninja itstool vala gtk+3.0-dev clutter-dev clutter-gtk-dev
libgee-dev libgnome-games-support-dev"
checkdepends="appstream-glib desktop-file-utils"
-source="https://download.gnome.org/sources/gnome-2048/${pkgver%.*}/gnome-2048-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/gnome-2048/${pkgver%.*}/gnome-2048-$pkgver.tar.xz
+ meson.patch
+ "
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="9063c31ef2a1126b92b6f52950237ac3878a8cbe4b1304e2c56e4bc7f8b99320f45ad27b3d7be3fb4cd2a1856bd11a171facc98bc917076118b83380668e4df8 gnome-2048-3.38.2.tar.xz"
+sha512sums="
+9063c31ef2a1126b92b6f52950237ac3878a8cbe4b1304e2c56e4bc7f8b99320f45ad27b3d7be3fb4cd2a1856bd11a171facc98bc917076118b83380668e4df8 gnome-2048-3.38.2.tar.xz
+a4603aab87fca8928d2194b5189dd4baeaab8f95f4fda9e306d1124f02ce44327734482c998f813e8232b26cb40b00ad33a7defc502e43eeaa3b3f4ac5546302 meson.patch
+"