aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-authenticator/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-authenticator/APKBUILD')
-rw-r--r--community/gnome-authenticator/APKBUILD49
1 files changed, 29 insertions, 20 deletions
diff --git a/community/gnome-authenticator/APKBUILD b/community/gnome-authenticator/APKBUILD
index 7010c39a833..7c6bf02f254 100644
--- a/community/gnome-authenticator/APKBUILD
+++ b/community/gnome-authenticator/APKBUILD
@@ -1,38 +1,47 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-authenticator
-pkgver=3.32.2
-pkgrel=9
+pkgver=4.4.0
+pkgrel=1
pkgdesc="Two-Factor Authentication application"
url="https://gitlab.gnome.org/World/Authenticator"
-# s390x blocked by libhandy
-# mips64 and riscv64 blocked by librsvg -> zbar
-arch="noarch !s390x !mips64 !riscv64"
+# 32-bit: pipewire-rs: https://gitlab.freedesktop.org/pipewire/pipewire-rs/-/issues/43
+arch="all !x86 !armhf !armv7"
license="GPL-3.0-only"
-depends="python3 py3-otp py3-beautifulsoup4 py3-pillow py3-pyfavicon py3-pyzbar
- py3-yoyo-migrations libhandy"
-makedepends="meson gtk+3.0-dev libsecret-dev zbar-dev gobject-introspection-dev
- py3-setuptools"
-checkdepends="appstream-glib desktop-file-utils"
-subpackages="$pkgname-lang"
-source="https://gitlab.gnome.org/World/Authenticator/-/archive/$pkgver/Authenticator-$pkgver.tar.gz
- dont-require-py3-gettext-support.patch
- c222f505a8bf623fbf057f9e1ae0a52e9df3edb7.patch"
+makedepends="
+ cargo
+ clang-dev
+ desktop-file-utils
+ gst-plugins-bad-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ gtk4.0-dev
+ libadwaita-dev
+ meson
+ openssl-dev
+ pipewire-dev
+ sqlite-dev
+ zbar-dev
+ "
+checkdepends="appstream-glib"
+subpackages="$pkgname-dbg $pkgname-lang"
+source="https://gitlab.gnome.org/World/Authenticator/-/archive/$pkgver/Authenticator-$pkgver.tar.bz2"
builddir="$srcdir/Authenticator-$pkgver"
+
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="3bd78354f4d18052d03650b455f07fb7fa9bb5cba0b6c92dcbfb5158dcf500f0b7f84e0be8942e0fbb74b1cefcd9019941c758538e05144c469bbe47b4355ce0 Authenticator-3.32.2.tar.gz
-04ce91e3c12503fb21728c39cf20ab1cd5c81f0ad7b5f6ecc875921c387df5fcc3edb4675e0015f1ba7eda71cf53246b9c14b819a11d5d151846112966aa10c0 dont-require-py3-gettext-support.patch
-2976e634578152ea2e3effd963a542395c19b9f28d0227727896e559e64e83421669c94a424e75c2e89924ce9fe578469c3ecc987f8d96f1bd80c88acfa03038 c222f505a8bf623fbf057f9e1ae0a52e9df3edb7.patch"
+sha512sums="
+721e842f21a012117bfcd41e572a80e47d613b707cde4546c4c743499e1449ed4382552afa1b25665fb1e64ced70124a8fe1c3203644aee174575db616de19c9 Authenticator-4.4.0.tar.bz2
+"