aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-authenticator/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-authenticator/APKBUILD')
-rw-r--r--community/gnome-authenticator/APKBUILD36
1 files changed, 25 insertions, 11 deletions
diff --git a/community/gnome-authenticator/APKBUILD b/community/gnome-authenticator/APKBUILD
index 1432c4d3872..7c6bf02f254 100644
--- a/community/gnome-authenticator/APKBUILD
+++ b/community/gnome-authenticator/APKBUILD
@@ -1,27 +1,41 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-authenticator
-pkgver=4.0.3
+pkgver=4.4.0
pkgrel=1
pkgdesc="Two-Factor Authentication application"
url="https://gitlab.gnome.org/World/Authenticator"
-# s390x, mips64, riscv64 blocked by libadwaita
-# x86, ppc64le building dependency ring v0.16.20 fails
-arch="all !s390x !mips64 !riscv64 !x86 !ppc64le"
+# 32-bit: pipewire-rs: https://gitlab.freedesktop.org/pipewire/pipewire-rs/-/issues/43
+arch="all !x86 !armhf !armv7"
license="GPL-3.0-only"
-makedepends="meson cargo gstreamer-dev gst-plugins-bad-dev gst-plugins-base-dev gtk4.0-dev libadwaita-dev zbar-dev"
-checkdepends="appstream-glib desktop-file-utils"
+makedepends="
+ cargo
+ clang-dev
+ desktop-file-utils
+ gst-plugins-bad-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ gtk4.0-dev
+ libadwaita-dev
+ meson
+ openssl-dev
+ pipewire-dev
+ sqlite-dev
+ zbar-dev
+ "
+checkdepends="appstream-glib"
subpackages="$pkgname-dbg $pkgname-lang"
-source="https://gitlab.gnome.org/World/Authenticator/-/archive/$pkgver/Authenticator-$pkgver.tar.gz"
+source="https://gitlab.gnome.org/World/Authenticator/-/archive/$pkgver/Authenticator-$pkgver.tar.bz2"
builddir="$srcdir/Authenticator-$pkgver"
+
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -29,5 +43,5 @@ package() {
}
sha512sums="
-cfd5d1a51de0f5b943a70949b354c1af01db05f3523cfcbb700352789c1dd85e13dd57c390b159b640247bf96e0107d01653464715e865f45724127f8a2458ce Authenticator-4.0.3.tar.gz
+721e842f21a012117bfcd41e572a80e47d613b707cde4546c4c743499e1449ed4382552afa1b25665fb1e64ced70124a8fe1c3203644aee174575db616de19c9 Authenticator-4.4.0.tar.bz2
"