aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-authenticator/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-authenticator/APKBUILD')
-rw-r--r--community/gnome-authenticator/APKBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/community/gnome-authenticator/APKBUILD b/community/gnome-authenticator/APKBUILD
index 76c5c63582..e89a70e228 100644
--- a/community/gnome-authenticator/APKBUILD
+++ b/community/gnome-authenticator/APKBUILD
@@ -1,21 +1,18 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome-authenticator
-pkgver=3.32.2
-pkgrel=11
+pkgver=4.0.3
+pkgrel=0
pkgdesc="Two-Factor Authentication application"
url="https://gitlab.gnome.org/World/Authenticator"
-# s390x and mips64 blocked by libhandy
-arch="noarch !s390x !mips64"
+# s390x, mips64, riscv64 blocked by libadwaita
+# x86, ppc64le building dependency ring v0.16.20 fails
+arch="all !s390x !mips64 !riscv64 !x86 !ppc64le"
license="GPL-3.0-only"
-depends="python3 py3-otp py3-beautifulsoup4 py3-pillow py3-pyfavicon py3-pyzbar
- py3-yoyo-migrations libhandy py3-setuptools"
-makedepends="meson gtk+3.0-dev libsecret-dev zbar-dev gobject-introspection-dev"
+makedepends="meson cargo gstreamer-dev gst-plugins-bad-dev gst-plugins-base-dev gtk4.0-dev libadwaita-dev zbar-dev"
checkdepends="appstream-glib desktop-file-utils"
subpackages="$pkgname-lang"
-source="https://gitlab.gnome.org/World/Authenticator/-/archive/$pkgver/Authenticator-$pkgver.tar.gz
- dont-require-py3-gettext-support.patch
- 0001-Remove-init_template-calls.patch"
+source="https://gitlab.gnome.org/World/Authenticator/-/archive/$pkgver/Authenticator-$pkgver.tar.gz"
builddir="$srcdir/Authenticator-$pkgver"
build() {
@@ -31,6 +28,6 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="3bd78354f4d18052d03650b455f07fb7fa9bb5cba0b6c92dcbfb5158dcf500f0b7f84e0be8942e0fbb74b1cefcd9019941c758538e05144c469bbe47b4355ce0 Authenticator-3.32.2.tar.gz
-04ce91e3c12503fb21728c39cf20ab1cd5c81f0ad7b5f6ecc875921c387df5fcc3edb4675e0015f1ba7eda71cf53246b9c14b819a11d5d151846112966aa10c0 dont-require-py3-gettext-support.patch
-bac065e33d70db2b27dd1302fc97d916173b07b32a84d5f3645c320c6a0a5c91ee8a031dd3114c94bda117196ef177942e119c87c5d9a9732efad2182b416223 0001-Remove-init_template-calls.patch"
+sha512sums="
+cfd5d1a51de0f5b943a70949b354c1af01db05f3523cfcbb700352789c1dd85e13dd57c390b159b640247bf96e0107d01653464715e865f45724127f8a2458ce Authenticator-4.0.3.tar.gz
+"