aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-autoar/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-autoar/APKBUILD')
-rw-r--r--community/gnome-autoar/APKBUILD63
1 files changed, 36 insertions, 27 deletions
diff --git a/community/gnome-autoar/APKBUILD b/community/gnome-autoar/APKBUILD
index 0235b946b4a..d135cafc76e 100644
--- a/community/gnome-autoar/APKBUILD
+++ b/community/gnome-autoar/APKBUILD
@@ -1,39 +1,48 @@
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-autoar
-pkgver=0.2.3
-pkgrel=0
+pkgver=0.4.4
+pkgrel=1
pkgdesc="GNOME archive extraction library"
+options="chmod-clean" # There are read-only test files
url="https://www.gnome.org/"
-arch="all !s390x"
-license="GPL"
-depends=""
-depends_dev="gnome-desktop-dev libarchive-dev"
-makedepends="$depends_dev vala"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
+arch="all"
+license="LGP-2.1-only"
+makedepends="
+ gobject-introspection-dev
+ gtk+3.0-dev
+ gtk-doc
+ libarchive-dev
+ meson
+ vala
+ "
+subpackages="$pkgname-dev"
source="https://download.gnome.org/sources/gnome-autoar/${pkgver%.*}/gnome-autoar-$pkgver.tar.xz"
-builddir="$srcdir/gnome-autoar-$pkgver"
+
+# secfixes:
+# 0.3.1-r0:
+# - CVE-2021-28650
+# - CVE-2020-36241
build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var
- make
+ abuild-meson \
+ -Db_lto=true \
+ -Dgtk=true \
+ -Dintrospection=enabled \
+ -Dvapi=true \
+ -Dtests=true \
+ -Dgtk_doc=false \
+ . output
+ meson compile -C output
}
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
}
-check() {
- cd "$builddir"
- make check
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="f87299817c52e7862a6c1cc950b1c362db8e7465e008d988e70245a203c728a9179400aac8601c399abe361e5a1ac4558b1190641ad3afa7224f883546fae7bc gnome-autoar-0.2.3.tar.xz"
+sha512sums="
+c38d3703e61d7338b97c362127bdc61f77d259eecd662f3963f28bfcb1ce7be8a948e9a57e79a8181a55dfc3635f671f2160ade947a1b5122204a2dc0025682d gnome-autoar-0.4.4.tar.xz
+"