aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-autoar/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-autoar/APKBUILD')
-rw-r--r--community/gnome-autoar/APKBUILD45
1 files changed, 27 insertions, 18 deletions
diff --git a/community/gnome-autoar/APKBUILD b/community/gnome-autoar/APKBUILD
index 83342919028..d135cafc76e 100644
--- a/community/gnome-autoar/APKBUILD
+++ b/community/gnome-autoar/APKBUILD
@@ -1,13 +1,21 @@
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-autoar
-pkgver=0.3.3
-pkgrel=0
+pkgver=0.4.4
+pkgrel=1
pkgdesc="GNOME archive extraction library"
+options="chmod-clean" # There are read-only test files
url="https://www.gnome.org/"
arch="all"
license="LGP-2.1-only"
-makedepends="gtk+3.0-dev libarchive-dev vala"
-subpackages="$pkgname-dev $pkgname-doc"
+makedepends="
+ gobject-introspection-dev
+ gtk+3.0-dev
+ gtk-doc
+ libarchive-dev
+ meson
+ vala
+ "
+subpackages="$pkgname-dev"
source="https://download.gnome.org/sources/gnome-autoar/${pkgver%.*}/gnome-autoar-$pkgver.tar.xz"
# secfixes:
@@ -16,24 +24,25 @@ source="https://download.gnome.org/sources/gnome-autoar/${pkgver%.*}/gnome-autoa
# - CVE-2020-36241
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var
- make
+ abuild-meson \
+ -Db_lto=true \
+ -Dgtk=true \
+ -Dintrospection=enabled \
+ -Dvapi=true \
+ -Dtests=true \
+ -Dgtk_doc=false \
+ . output
+ meson compile -C output
}
-package() {
- make DESTDIR="$pkgdir" install
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
}
-check() {
- make check
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
sha512sums="
-41cda2670506e9b3f79c4995d2fdfbd5024777d8f8b3f85a2010af4e5f4303743d26ad9cad787c995362f83b65617ed5773d972c8aa2c7bdcd358d873cb86ec4 gnome-autoar-0.3.3.tar.xz
+c38d3703e61d7338b97c362127bdc61f77d259eecd662f3963f28bfcb1ce7be8a948e9a57e79a8181a55dfc3635f671f2160ade947a1b5122204a2dc0025682d gnome-autoar-0.4.4.tar.xz
"