aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-autoar/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-autoar/APKBUILD')
-rw-r--r--community/gnome-autoar/APKBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/community/gnome-autoar/APKBUILD b/community/gnome-autoar/APKBUILD
index b64cf8e0c27..d135cafc76e 100644
--- a/community/gnome-autoar/APKBUILD
+++ b/community/gnome-autoar/APKBUILD
@@ -1,15 +1,21 @@
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-autoar
-pkgver=0.4.0
-pkgrel=0
+pkgver=0.4.4
+pkgrel=1
pkgdesc="GNOME archive extraction library"
options="chmod-clean" # There are read-only test files
url="https://www.gnome.org/"
arch="all"
license="LGP-2.1-only"
-makedepends="meson gtk+3.0-dev libarchive-dev gobject-introspection-dev vala
- gtk-doc"
-subpackages="$pkgname-dev $pkgname-doc"
+makedepends="
+ gobject-introspection-dev
+ gtk+3.0-dev
+ gtk-doc
+ libarchive-dev
+ meson
+ vala
+ "
+subpackages="$pkgname-dev"
source="https://download.gnome.org/sources/gnome-autoar/${pkgver%.*}/gnome-autoar-$pkgver.tar.xz"
# secfixes:
@@ -19,17 +25,18 @@ source="https://download.gnome.org/sources/gnome-autoar/${pkgver%.*}/gnome-autoa
build() {
abuild-meson \
+ -Db_lto=true \
-Dgtk=true \
-Dintrospection=enabled \
-Dvapi=true \
-Dtests=true \
- -Dgtk_doc=true \
+ -Dgtk_doc=false \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -37,5 +44,5 @@ package() {
}
sha512sums="
-ab4ef47ef65e4fa0dc652b19a9eb94cc307013e4c7ced6980cedc7ced20fb77d53e1807c20b14a69c1ddc536c4ed0007062481e258d36c07e3be837537916b7f gnome-autoar-0.4.0.tar.xz
+c38d3703e61d7338b97c362127bdc61f77d259eecd662f3963f28bfcb1ce7be8a948e9a57e79a8181a55dfc3635f671f2160ade947a1b5122204a2dc0025682d gnome-autoar-0.4.4.tar.xz
"