aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-backgrounds/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-backgrounds/APKBUILD')
-rw-r--r--community/gnome-backgrounds/APKBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/community/gnome-backgrounds/APKBUILD b/community/gnome-backgrounds/APKBUILD
index 661dc14b84e..014a2be16a4 100644
--- a/community/gnome-backgrounds/APKBUILD
+++ b/community/gnome-backgrounds/APKBUILD
@@ -1,29 +1,25 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=gnome-backgrounds
-pkgver=3.34.0
-pkgrel=2
+pkgver=46.0
+pkgrel=0
pkgdesc="Default wallpaper set for GNOME"
url="https://gitlab.gnome.org/GNOME/gnome-backgrounds"
arch="noarch"
-license="GPL-2.0-or-later CC-BY-2.0 CC-BY-SA-2.0 CC-BY-SA-3.0"
+license="GPL-2.0-or-later AND CC-BY-2.0 AND CC-BY-SA-2.0 AND CC-BY-SA-3.0"
makedepends="meson gettext-dev"
options="!check" # no tests for wallpapers
-subpackages="$pkgname-lang"
source="https://download.gnome.org/sources/gnome-backgrounds/${pkgver%.*}/gnome-backgrounds-$pkgver.tar.xz"
build() {
- meson \
- --prefix=/usr \
- --buildtype=plain \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- output .
- ninja -C output
+ abuild-meson output .
+ meson compile -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="bea6df85611a845c1013091dfccfd1d1fc697781a74348d936c15f8cec1ace765c37e6f57fed403cc2c6a91a18e522c8cc3db74b2c2327cd3ed71371075a9834 gnome-backgrounds-3.34.0.tar.xz"
+sha512sums="
+d6b7c5bcc74ea36e9cc2757bf41eb7a5d3794f5782aeee9087b3ff1a17b7526dfbde2a0568d90e41ae707c9c290f4c09c2edd16f4768d8ca4889a96badb9e2b6 gnome-backgrounds-46.0.tar.xz
+"