aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-bluetooth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-bluetooth/APKBUILD')
-rw-r--r--community/gnome-bluetooth/APKBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/community/gnome-bluetooth/APKBUILD b/community/gnome-bluetooth/APKBUILD
index 8e584e06375..bb2d457b499 100644
--- a/community/gnome-bluetooth/APKBUILD
+++ b/community/gnome-bluetooth/APKBUILD
@@ -1,15 +1,16 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=gnome-bluetooth
-pkgver=42.2
+pkgver=46.0
pkgrel=0
pkgdesc="The GNOME Bluetooth Subsystem"
url="https://wiki.gnome.org/Projects/GnomeBluetooth"
-arch="all"
+# Fails to build on s390x
+arch="all !s390x"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
depends="
- bluez-obexd
bluez>=5
+ obexd-enhanced
"
makedepends="
eudev-dev
@@ -32,12 +33,12 @@ if [ "$CARCH" = "armhf" ]; then
fi
build() {
- abuild-meson output .
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson -Db_lto=true . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -47,6 +48,6 @@ package() {
}
sha512sums="
-79c1846eb084fa8a80b070e2c5731040d23bc9c4cdd2c6f36d4acba9b9eb5cb828a61540b82e3bb993befa8fde1704f089d539c82291f1a6a16444182dd97f73 gnome-bluetooth-42.2.tar.xz
+48ed8aeaa59aba1997991a6ae6113a4d3c9e286aa4e34f3f2611e33582ffa53f9f3f5a81052320292ccb576904d0f3cf8074c0fff6d0f56995266188441e6f7b gnome-bluetooth-46.0.tar.xz
68ea6502a469d800e92d8984984cfddfa66e7bf8a0252d52a2338843d183680c84aa7ec6c4c7d14a250515b34b71d89364480c809743ba9e7ef30473b8ebb5a8 61-gnome-bluetooth-rfkill.rules
"