aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-bluetooth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-bluetooth/APKBUILD')
-rw-r--r--community/gnome-bluetooth/APKBUILD52
1 files changed, 32 insertions, 20 deletions
diff --git a/community/gnome-bluetooth/APKBUILD b/community/gnome-bluetooth/APKBUILD
index 7f6e7da84b8..bb2d457b499 100644
--- a/community/gnome-bluetooth/APKBUILD
+++ b/community/gnome-bluetooth/APKBUILD
@@ -1,27 +1,44 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=gnome-bluetooth
-pkgver=3.34.5
-pkgrel=1
+pkgver=46.0
+pkgrel=0
pkgdesc="The GNOME Bluetooth Subsystem"
url="https://wiki.gnome.org/Projects/GnomeBluetooth"
-arch="all"
+# Fails to build on s390x
+arch="all !s390x"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
-depends="hicolor-icon-theme bluez>=5 bluez-obexd"
-makedepends="dconf-dev gobject-introspection-dev libnotify-dev libxi-dev
- dbus-glib-dev gtk+3.0-dev eudev-dev libcanberra-dev meson"
-checkdepends="py3-dbus py3-gobject3"
+depends="
+ bluez>=5
+ obexd-enhanced
+ "
+makedepends="
+ eudev-dev
+ glib-dev
+ gobject-introspection-dev
+ gsound-dev
+ gtk4.0-dev
+ libadwaita-dev
+ libnotify-dev
+ meson
+ upower-dev
+ "
+checkdepends="py3-dbus py3-gobject3 py3-dbusmock"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs"
source="https://download.gnome.org/sources/gnome-bluetooth/${pkgver%.*}/gnome-bluetooth-$pkgver.tar.xz
61-gnome-bluetooth-rfkill.rules"
+if [ "$CARCH" = "armhf" ]; then
+ options="!check"; # tests fail on armhf
+fi
+
build() {
- abuild-meson output .
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson -Db_lto=true . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -30,12 +47,7 @@ package() {
"$pkgdir/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules"
}
-libs() {
- default_libs
- replaces="gnome-bluetooth"
- mkdir -p "$subpkgdir"/usr/share
- mv "$pkgdir"/usr/share/icons "$subpkgdir"/usr/share/
-}
-
-sha512sums="48431b3d19083705a6623442c5cd2d6c14962cdf30fc599ba47dceb6612b80142af77e1b6df142b530cb1015638081a06de38a3034177e0d05a354c40f19d9e5 gnome-bluetooth-3.34.5.tar.xz
-80b7fd0bc3e0f82c8d2d609ffed634200e63f61d9a134445df8e8511756b7fb423d338a1d12e42b91c57243097beaa3d4662856ec0507fb19a29b6de7ee9e4de 61-gnome-bluetooth-rfkill.rules"
+sha512sums="
+48ed8aeaa59aba1997991a6ae6113a4d3c9e286aa4e34f3f2611e33582ffa53f9f3f5a81052320292ccb576904d0f3cf8074c0fff6d0f56995266188441e6f7b gnome-bluetooth-46.0.tar.xz
+68ea6502a469d800e92d8984984cfddfa66e7bf8a0252d52a2338843d183680c84aa7ec6c4c7d14a250515b34b71d89364480c809743ba9e7ef30473b8ebb5a8 61-gnome-bluetooth-rfkill.rules
+"