aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-calculator/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-calculator/APKBUILD')
-rw-r--r--community/gnome-calculator/APKBUILD38
1 files changed, 26 insertions, 12 deletions
diff --git a/community/gnome-calculator/APKBUILD b/community/gnome-calculator/APKBUILD
index 70bd7130148..cca04a9f7da 100644
--- a/community/gnome-calculator/APKBUILD
+++ b/community/gnome-calculator/APKBUILD
@@ -1,29 +1,43 @@
# Contributors: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=gnome-calculator
-pkgver=41.0
+pkgver=46.0
pkgrel=0
pkgdesc="Calculator for solving mathematical equations"
url="https://wiki.gnome.org/Apps/Calculator"
-# s390x, mips64 and riscv64 blocked by rust -> libhandy1
-arch="all !s390x !mips !mips64 !riscv64"
+# s390x: doubt anyone would run this on a mainframe
+arch="all !s390x"
license="GPL-3.0-or-later"
-makedepends="vala gtksourceview4-dev glib-dev gtk+3.0-dev libsoup-dev
- libxml2-dev meson mpc1-dev mpfr-dev itstool libgee-dev libhandy1-dev"
-subpackages="$pkgname-doc $pkgname-lang $pkgname-dev"
-source="https://download.gnome.org/sources/gnome-calculator/${pkgver%.*}/gnome-calculator-$pkgver.tar.xz"
+makedepends="
+ glib-dev
+ gtksourceview5-dev
+ gtk4.0-dev
+ itstool
+ libadwaita-dev
+ libgee-dev
+ libsoup3-dev
+ libxml2-dev
+ meson
+ mpc1-dev
+ mpfr-dev
+ vala
+ "
+subpackages="$pkgname-devhelp $pkgname-doc $pkgname-lang $pkgname-dev"
+source="https://download.gnome.org/sources/gnome-calculator/${pkgver%%.*}/gnome-calculator-$pkgver.tar.xz"
if [ "$CARCH" = armhf ]; then
options="$options !check" # tests time out on armhf
fi
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson \
+ -Db_lto=true \
+ . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -31,5 +45,5 @@ package() {
}
sha512sums="
-c64538c9e9a183411263c88eb74a831a4f89f0eca2d496f1eed98ee6051737110ab992931ec75c0566c8528b209ba4f4103af3497a7ad29643814e4d2ef70c54 gnome-calculator-41.0.tar.xz
+b2af034df6c0e94519aef505e960ef3b31f52038b8224d7688d32de8d4b061ac9ee2a127efdce16679ae8863c2fc625476302571db32e9d9859f9800000466c0 gnome-calculator-46.0.tar.xz
"