aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-chess/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-chess/APKBUILD')
-rw-r--r--community/gnome-chess/APKBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/community/gnome-chess/APKBUILD b/community/gnome-chess/APKBUILD
index eab60d5567c..3851674b331 100644
--- a/community/gnome-chess/APKBUILD
+++ b/community/gnome-chess/APKBUILD
@@ -1,24 +1,31 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-chess
-pkgver=41.0
+pkgver=46.0
pkgrel=0
-arch="all !s390x !mips !mips64 !riscv64" # limited by librsvg -> rust
+arch="all"
url="https://wiki.gnome.org/Apps/Chess"
pkgdesc="Play the classic two-player boardgame of chess"
license="GPL-3.0-or-later"
-makedepends="meson ninja itstool vala gtk4.0-dev librsvg-dev"
-checkdepends="desktop-file-utils"
+makedepends="
+ desktop-file-utils
+ gtk4.0-dev
+ itstool
+ libadwaita-dev
+ librsvg-dev
+ meson
+ vala
+ "
source="https://download.gnome.org/sources/gnome-chess/${pkgver%.*}/gnome-chess-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson -Db_lto=true . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -26,5 +33,5 @@ package() {
}
sha512sums="
-642c6a6462217a047f7a20bf31229742d37477c41883f9d65332deab3c0f872f99dda760b6031d508dc70bf359dff9e86db84e4b82da06edec3261b571a3dec0 gnome-chess-41.0.tar.xz
+e605b9750fdc77a0d2b6973f127fb2cf5fadb15080add728c80a8be5ce02035ff6cadb0351751a0612f09632602fe532405d62c68828fd0ec4bf83b9bd11301a gnome-chess-46.0.tar.xz
"