aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-contacts/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-contacts/APKBUILD')
-rw-r--r--community/gnome-contacts/APKBUILD40
1 files changed, 28 insertions, 12 deletions
diff --git a/community/gnome-contacts/APKBUILD b/community/gnome-contacts/APKBUILD
index 05cd5d6fdeb..33251b57a5f 100644
--- a/community/gnome-contacts/APKBUILD
+++ b/community/gnome-contacts/APKBUILD
@@ -1,30 +1,46 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=gnome-contacts
-pkgver=3.38
+pkgver=46.0
pkgrel=0
pkgdesc="A contacts manager for GNOME"
url="https://wiki.gnome.org/Apps/Contacts"
-arch="all !s390x !mips !mips64" # libhandy is missing
+# s390x: doubt anyone would use this on a mainframe
+arch="all !s390x"
license="GPL-2.0-or-later"
-makedepends="meson vala folks-dev libgee-dev glib-dev gnome-desktop-dev
- gnome-online-accounts-dev cheese-dev evolution-data-server-dev telepathy-glib-dev
- libhandy1-dev gtk+3.0-dev"
-checkdepends="appstream-glib desktop-file-utils"
+makedepends="
+ desktop-file-utils
+ evolution-data-server-dev
+ folks-dev
+ glib-dev
+ gnome-desktop-dev
+ gnome-online-accounts-dev
+ gtk4.0-dev
+ libadwaita-dev
+ libgee-dev
+ libportal-dev
+ libqrencode-dev
+ meson
+ telepathy-glib-dev
+ vala
+ "
+checkdepends="appstream-glib"
subpackages="$pkgname-lang $pkgname-doc"
-source="https://download.gnome.org/sources/gnome-contacts/$pkgver/gnome-contacts-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/gnome-contacts/${pkgver%.*}/gnome-contacts-$pkgver.tar.xz"
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson -Db_lto=true . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="bcd7f654b14833a7f281c8b1b099ed0f39df515a8d284e45942f0800691c54736eefbd79d7263284d314500806708b42433a861fca3e500c9aef6d38e2ce08f8 gnome-contacts-3.38.tar.xz"
+sha512sums="
+adadbb4038053e402f131f530b61fa1c33008eac819d2c03e0a024080bc7e5e24b022a0e9d773ffa03e20324296338d1c3115d25a39f6a3fddd4480de3c8980e gnome-contacts-46.0.tar.xz
+"