aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-font-viewer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-font-viewer/APKBUILD')
-rw-r--r--community/gnome-font-viewer/APKBUILD27
1 files changed, 18 insertions, 9 deletions
diff --git a/community/gnome-font-viewer/APKBUILD b/community/gnome-font-viewer/APKBUILD
index 58cb5202bd7..482c54b0077 100644
--- a/community/gnome-font-viewer/APKBUILD
+++ b/community/gnome-font-viewer/APKBUILD
@@ -1,26 +1,35 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=gnome-font-viewer
-pkgver=40.0
+pkgver=46.0
pkgrel=0
pkgdesc="View fonts on your system"
url="https://gitlab.gnome.org/GNOME/gnome-font-viewer"
-# s390x, mips64 and riscv64 blocked by rust -> libhandy1
-arch="all !s390x !mips64 !riscv64"
+arch="all"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
-makedepends="glib-dev gtk+3.0-dev harfbuzz-dev fontconfig-dev freetype-dev
- gnome-desktop-dev meson libhandy1-dev"
+makedepends="
+ fontconfig-dev
+ freetype-dev
+ glib-dev
+ gnome-desktop-dev
+ gtk4.0-dev
+ harfbuzz-dev
+ libadwaita-dev
+ meson
+ "
options="!check" # no tests
subpackages="$pkgname-lang"
source="https://download.gnome.org/sources/gnome-font-viewer/${pkgver%.*}/gnome-font-viewer-$pkgver.tar.xz"
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson -Db_lto=true . output
+ meson compile -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="c82044e6750494d693cf631abe7fb76c655b58965ccd1ca08f512f0e79c40e9f207997465908b99e5813f350ca05ea8e76f029be79f3008173c49f3c5a4ee23d gnome-font-viewer-40.0.tar.xz"
+sha512sums="
+c97e109c16d59b22afa1b8c9736b99cf687284783691e624e331218d39a5ac509e53555416672bf8967ed8611ac25e7817766f8d5c66ca73cd2309b2405c2ebe gnome-font-viewer-46.0.tar.xz
+"