aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-keyring/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-keyring/APKBUILD')
-rw-r--r--community/gnome-keyring/APKBUILD43
1 files changed, 33 insertions, 10 deletions
diff --git a/community/gnome-keyring/APKBUILD b/community/gnome-keyring/APKBUILD
index 479f6601e9e..5926674d36e 100644
--- a/community/gnome-keyring/APKBUILD
+++ b/community/gnome-keyring/APKBUILD
@@ -1,30 +1,50 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=gnome-keyring
-pkgver=40.0
+pkgver=46.1
pkgrel=0
pkgdesc="GNOME keyring"
url="https://wiki.gnome.org//Projects/GnomeKeyring"
arch="all"
license="GPL-2.0-only LGPL-2.0-only"
-makedepends="gtk+3.0-dev gcr-dev libcap-ng-dev linux-pam-dev
- intltool gobject-introspection-dev gtk-doc libxslt
- openssh-client libgcrypt-dev"
-checkdepends="python3 dbus-x11 xvfb-run"
+# the gcr binaries are needed for things to open the keyring via libsecret
+depends="gcr"
+makedepends="
+ autoconf
+ automake
+ gcr-dev
+ gobject-introspection-dev
+ gtk+3.0-dev
+ gtk-doc
+ intltool
+ libcap-ng-dev
+ libgcrypt-dev
+ libxslt
+ linux-pam-dev
+ openssh-client
+ "
+checkdepends="
+ dbus-x11
+ python3
+ xvfb-run
+ "
provides="dbus:org.freedesktop.Secrets"
# Highest priority of the bunch since it has the least deps
provider_priority=100
-options="!check" # Failing tests on the builders :/
+options="!check" # Failing tests on 32-bit architectures
subpackages="$pkgname-lang $pkgname-doc"
-source="https://download.gnome.org/sources/gnome-keyring/${pkgver%.*}/gnome-keyring-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/gnome-keyring/${pkgver%.*}/gnome-keyring-$pkgver.tar.xz
+ 0001-build-Use-p11_module_configs-as-default-pkcs11-confi.patch"
build() {
+ export LDFLAGS="$LDFLAGS -lintl"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
- --with-pam-dir=/lib/security
+ --with-pam-dir=/lib/security \
+ --with-libcap-ng=no
make
}
@@ -37,4 +57,7 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="c9cb0dca8c46ee712200c96c20663a8d5cd39f07801a04e1afca26550a04af6cb369b53a1f29638bf4c8a29f418a69f565befcf4d08df5b0d30fb31894ecf95e gnome-keyring-40.0.tar.xz"
+sha512sums="
+82d9685a87b43c6aa1f377114af389675836df4b5c26d43d6843f1dfac6ae0eb771a4ac67f71e5a2f5b88cbdbb5300d63bfcfd8087ee60463a9579d242c6b884 gnome-keyring-46.1.tar.xz
+53e04eade3579fe5d65d11d6cde6c5fdffc9f73a3a7f372b1f4dbc7437212e753123c12854d3a5a7a22f3beb1b00604eec0371615ceb0f7024cb38cf35e33065 0001-build-Use-p11_module_configs-as-default-pkcs11-confi.patch
+"