aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-podcasts/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-podcasts/APKBUILD')
-rw-r--r--community/gnome-podcasts/APKBUILD43
1 files changed, 27 insertions, 16 deletions
diff --git a/community/gnome-podcasts/APKBUILD b/community/gnome-podcasts/APKBUILD
index 136cc241285..70f8f98632e 100644
--- a/community/gnome-podcasts/APKBUILD
+++ b/community/gnome-podcasts/APKBUILD
@@ -1,38 +1,50 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-podcasts
-pkgver=0.5.1
+pkgver=0.7.1
pkgrel=0
pkgdesc="Podcast app for GNOME"
url="https://wiki.gnome.org/Apps/Podcasts"
-# x86 blocked by crashing Rust
# armv7 blocked by failing test
-# s390x and riscv64 blocked by rust/cargo
-arch="all !s390x !armv7 !riscv64"
+arch="all !armv7"
license="GPL-3.0-or-later"
depends="gst-plugins-good"
-makedepends="meson gtk+3.0-dev gstreamer-dev libhandy1-dev sqlite-dev openssl1.1-compat-dev
- dbus-dev gst-plugins-base-dev gst-plugins-bad-dev cargo bash"
-checkdepends="desktop-file-utils appstream-glib xvfb-run"
+makedepends="
+ bash
+ cargo
+ dbus-dev
+ desktop-file-utils
+ gst-plugins-bad-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ gtk4.0-dev
+ libadwaita-dev
+ meson
+ openssl-dev>3
+ sqlite-dev
+ "
+checkdepends="
+ appstream-glib
+ xvfb-run
+ "
options="!check" # needs the thing to be installed first
subpackages="$pkgname-lang"
-source="https://gitlab.gnome.org/World/podcasts/uploads/de438a4d62196bddd134bb155a812fe1/gnome-podcasts-$pkgver.tar.xz
- meson-0.60.patch
- "
+source="https://gitlab.gnome.org/World/podcasts/-/archive/$pkgver/podcasts-$pkgver.tar.gz"
+builddir="$srcdir/podcasts-$pkgver"
prepare() {
default_prepare
- sed 's| /usr/bin/sh|/bin/sh|' -i scripts/test.sh
+ sed 's| /bin/bash|/bin/sh|' -i scripts/test.sh
}
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- xvfb-run meson test --no-rebuild -v -C output
+ xvfb-run meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -40,6 +52,5 @@ package() {
}
sha512sums="
-7b50112fc1f7bbbec1b916ba4490738752af603d5ddf3e0621dc18b6bacb488ba557e895529b940b9e039870aa5577550cf807c40011187d7d41c326a46d2803 gnome-podcasts-0.5.1.tar.xz
-4c75425d626de3a35616b6a9e89538b5d89dc920bc94b5cf73c62ae8985e67159778069fa2e3363ea3a5ae3e423cc8df274d09361c6bcaa3ea678f1345faae65 meson-0.60.patch
+93fcc7b26675ddc19d753c97fc7b34f8438072611abbb5686984a03a7498e51124e09c81988a7a2ad0bf06da9585866eb01705576f0663fb203522fd1276f959 podcasts-0.7.1.tar.gz
"