aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-podcasts/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-podcasts/APKBUILD')
-rw-r--r--community/gnome-podcasts/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/community/gnome-podcasts/APKBUILD b/community/gnome-podcasts/APKBUILD
new file mode 100644
index 00000000000..35905e394cb
--- /dev/null
+++ b/community/gnome-podcasts/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnome-podcasts
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="Podcast app for GNOME"
+url="https://wiki.gnome.org/Apps/Podcasts"
+# armv7 blocked by failing test
+arch="all !armv7"
+license="GPL-3.0-or-later"
+depends="gst-plugins-good"
+makedepends="
+ bash
+ cargo
+ dbus-dev
+ desktop-file-utils
+ gst-plugins-bad-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ gtk4.0-dev
+ libadwaita-dev
+ meson
+ openssl-dev>3
+ sqlite-dev
+ "
+checkdepends="
+ appstream-glib
+ xvfb-run
+ "
+options="!check" # needs the thing to be installed first
+subpackages="$pkgname-lang"
+source="https://gitlab.gnome.org/World/podcasts/uploads/7f5cb601b1eea22cc473077e8c0dcfad/gnome-podcasts-$pkgver.tar.xz
+ "
+
+
+prepare() {
+ default_prepare
+
+ sed 's| /usr/bin/sh|/bin/sh|' -i scripts/test.sh
+}
+
+build() {
+ abuild-meson . output
+ meson compile -C output
+}
+
+check() {
+ xvfb-run meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+59342a02314ed8062138c61c4d762756169307460d425c2f16110fcbfb3ea2dd33386ec968d7982f324c239180f515fc524ffd49f9d41e2b13691aa15134a737 gnome-podcasts-0.6.1.tar.xz
+"