aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-podcasts/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-podcasts/APKBUILD')
-rw-r--r--community/gnome-podcasts/APKBUILD55
1 files changed, 35 insertions, 20 deletions
diff --git a/community/gnome-podcasts/APKBUILD b/community/gnome-podcasts/APKBUILD
index a57e1622d21..70f8f98632e 100644
--- a/community/gnome-podcasts/APKBUILD
+++ b/community/gnome-podcasts/APKBUILD
@@ -1,41 +1,56 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-podcasts
-pkgver=0.4.7
-pkgrel=2
+pkgver=0.7.1
+pkgrel=0
pkgdesc="Podcast app for GNOME"
url="https://wiki.gnome.org/Apps/Podcasts"
-arch="all !s390x !x86" # rust crashing on x86, missing deps on s390x
+# armv7 blocked by failing test
+arch="all !armv7"
license="GPL-3.0-or-later"
-makedepends="meson gtk+3.0-dev gstreamer-dev libhandy-dev sqlite-dev openssl-dev
- dbus-dev gst-plugins-base-dev gst-plugins-bad-dev cargo bash"
-checkdepends="desktop-file-utils appstream-glib xvfb-run"
+depends="gst-plugins-good"
+makedepends="
+ bash
+ cargo
+ dbus-dev
+ desktop-file-utils
+ gst-plugins-bad-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ gtk4.0-dev
+ libadwaita-dev
+ meson
+ openssl-dev>3
+ sqlite-dev
+ "
+checkdepends="
+ appstream-glib
+ xvfb-run
+ "
+options="!check" # needs the thing to be installed first
subpackages="$pkgname-lang"
-source="https://gitlab.gnome.org/World/podcasts/uploads/90c4f40f529ff91dabac5d7cbbc0f5ed/gnome-podcasts-$pkgver.tar.xz"
+source="https://gitlab.gnome.org/World/podcasts/-/archive/$pkgver/podcasts-$pkgver.tar.gz"
+builddir="$srcdir/podcasts-$pkgver"
prepare() {
default_prepare
- sed 's| /usr/bin/sh|/bin/sh|' -i scripts/test.sh
+ sed 's| /bin/bash|/bin/sh|' -i scripts/test.sh
}
build() {
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --buildtype=plain \
- . output
- ninja -C output
+ abuild-meson . output
+ meson compile -C output
}
check() {
- xvfb-run ninja -C output test
+ xvfb-run meson test --no-rebuild --print-errorlogs -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="050eaf96a7d36fa97d4e593d4741cbeb6413b7a7346a31831cf2baeaebaff25959cefbd4bb3f656601a61802a25ddf7c1f5eac2a814fb29b464552861716387e gnome-podcasts-0.4.7.tar.xz"
+sha512sums="
+93fcc7b26675ddc19d753c97fc7b34f8438072611abbb5686984a03a7498e51124e09c81988a7a2ad0bf06da9585866eb01705576f0663fb203522fd1276f959 podcasts-0.7.1.tar.gz
+"