aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-podcasts/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-podcasts/APKBUILD')
-rw-r--r--community/gnome-podcasts/APKBUILD46
1 files changed, 33 insertions, 13 deletions
diff --git a/community/gnome-podcasts/APKBUILD b/community/gnome-podcasts/APKBUILD
index 9152d741e20..70f8f98632e 100644
--- a/community/gnome-podcasts/APKBUILD
+++ b/community/gnome-podcasts/APKBUILD
@@ -1,36 +1,56 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-podcasts
-pkgver=0.4.8
-pkgrel=1
+pkgver=0.7.1
+pkgrel=0
pkgdesc="Podcast app for GNOME"
url="https://wiki.gnome.org/Apps/Podcasts"
-arch="all !s390x !mips !mips64 !armv7" # rust crashing on x86, missing deps on s390x and mips, failing test on armv7
+# armv7 blocked by failing test
+arch="all !armv7"
license="GPL-3.0-or-later"
-depends="gst-plugins-base gst-plugins-bad gst-plugins-good"
-makedepends="meson gtk+3.0-dev gstreamer-dev libhandy-dev sqlite-dev openssl-dev
- dbus-dev gst-plugins-base-dev gst-plugins-bad-dev cargo bash"
-checkdepends="desktop-file-utils appstream-glib xvfb-run"
+depends="gst-plugins-good"
+makedepends="
+ bash
+ cargo
+ dbus-dev
+ desktop-file-utils
+ gst-plugins-bad-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ gtk4.0-dev
+ libadwaita-dev
+ meson
+ openssl-dev>3
+ sqlite-dev
+ "
+checkdepends="
+ appstream-glib
+ xvfb-run
+ "
+options="!check" # needs the thing to be installed first
subpackages="$pkgname-lang"
-source="https://gitlab.gnome.org/World/podcasts/uploads/cf61f00c7ac92ddef81c4f5ed7e737a7/gnome-podcasts-$pkgver.tar.xz"
+source="https://gitlab.gnome.org/World/podcasts/-/archive/$pkgver/podcasts-$pkgver.tar.gz"
+builddir="$srcdir/podcasts-$pkgver"
prepare() {
default_prepare
- sed 's| /usr/bin/sh|/bin/sh|' -i scripts/test.sh
+ sed 's| /bin/bash|/bin/sh|' -i scripts/test.sh
}
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- xvfb-run meson test --no-rebuild -v -C output
+ xvfb-run meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="2083c63a45c8a4608667d4300e1a28cf6c7bd7f375ee7eaa0e377e96cac37bf8c5c79efaea0872ca4b69b219254b711681be20e40b03c6366cc60eecbd223338 gnome-podcasts-0.4.8.tar.xz"
+sha512sums="
+93fcc7b26675ddc19d753c97fc7b34f8438072611abbb5686984a03a7498e51124e09c81988a7a2ad0bf06da9585866eb01705576f0663fb203522fd1276f959 podcasts-0.7.1.tar.gz
+"