aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-podcasts/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-podcasts/APKBUILD')
-rw-r--r--community/gnome-podcasts/APKBUILD44
1 files changed, 30 insertions, 14 deletions
diff --git a/community/gnome-podcasts/APKBUILD b/community/gnome-podcasts/APKBUILD
index ff59cbc18be..70f8f98632e 100644
--- a/community/gnome-podcasts/APKBUILD
+++ b/community/gnome-podcasts/APKBUILD
@@ -1,40 +1,56 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-podcasts
-pkgver=0.4.9
-pkgrel=2
+pkgver=0.7.1
+pkgrel=0
pkgdesc="Podcast app for GNOME"
url="https://wiki.gnome.org/Apps/Podcasts"
-# x86 blocked by crashing Rust
# armv7 blocked by failing test
-# s390x, mips64 and riscv64 blocked by rust/cargo
-arch="all !s390x !mips64 !armv7 !riscv64"
+arch="all !armv7"
license="GPL-3.0-or-later"
depends="gst-plugins-good"
-makedepends="meson gtk+3.0-dev gstreamer-dev libhandy1-dev sqlite-dev openssl1.1-compat-dev
- dbus-dev gst-plugins-base-dev gst-plugins-bad-dev cargo bash"
-checkdepends="desktop-file-utils appstream-glib xvfb-run"
+makedepends="
+ bash
+ cargo
+ dbus-dev
+ desktop-file-utils
+ gst-plugins-bad-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ gtk4.0-dev
+ libadwaita-dev
+ meson
+ openssl-dev>3
+ sqlite-dev
+ "
+checkdepends="
+ appstream-glib
+ xvfb-run
+ "
options="!check" # needs the thing to be installed first
subpackages="$pkgname-lang"
-source="https://gitlab.gnome.org/World/podcasts/uploads/e07d05de378066ec528729e8897e1d1b/gnome-podcasts-$pkgver.tar.xz"
+source="https://gitlab.gnome.org/World/podcasts/-/archive/$pkgver/podcasts-$pkgver.tar.gz"
+builddir="$srcdir/podcasts-$pkgver"
prepare() {
default_prepare
- sed 's| /usr/bin/sh|/bin/sh|' -i scripts/test.sh
+ sed 's| /bin/bash|/bin/sh|' -i scripts/test.sh
}
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- xvfb-run meson test --no-rebuild -v -C output
+ xvfb-run meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="3131089e033801b58edf28d07acbae0b0be10c12a42070a37d91f4886b7dec3603a48d7cd88a55fb71ef91431e494a58bebd8ab8bff6bc32147913c395ad43ba gnome-podcasts-0.4.9.tar.xz"
+sha512sums="
+93fcc7b26675ddc19d753c97fc7b34f8438072611abbb5686984a03a7498e51124e09c81988a7a2ad0bf06da9585866eb01705576f0663fb203522fd1276f959 podcasts-0.7.1.tar.gz
+"