aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-podcasts/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-podcasts/APKBUILD')
-rw-r--r--community/gnome-podcasts/APKBUILD43
1 files changed, 30 insertions, 13 deletions
diff --git a/community/gnome-podcasts/APKBUILD b/community/gnome-podcasts/APKBUILD
index ff59cbc18be..35905e394cb 100644
--- a/community/gnome-podcasts/APKBUILD
+++ b/community/gnome-podcasts/APKBUILD
@@ -1,22 +1,37 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-podcasts
-pkgver=0.4.9
-pkgrel=2
+pkgver=0.6.1
+pkgrel=1
pkgdesc="Podcast app for GNOME"
url="https://wiki.gnome.org/Apps/Podcasts"
-# x86 blocked by crashing Rust
# armv7 blocked by failing test
-# s390x, mips64 and riscv64 blocked by rust/cargo
-arch="all !s390x !mips64 !armv7 !riscv64"
+arch="all !armv7"
license="GPL-3.0-or-later"
depends="gst-plugins-good"
-makedepends="meson gtk+3.0-dev gstreamer-dev libhandy1-dev sqlite-dev openssl1.1-compat-dev
- dbus-dev gst-plugins-base-dev gst-plugins-bad-dev cargo bash"
-checkdepends="desktop-file-utils appstream-glib xvfb-run"
+makedepends="
+ bash
+ cargo
+ dbus-dev
+ desktop-file-utils
+ gst-plugins-bad-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ gtk4.0-dev
+ libadwaita-dev
+ meson
+ openssl-dev>3
+ sqlite-dev
+ "
+checkdepends="
+ appstream-glib
+ xvfb-run
+ "
options="!check" # needs the thing to be installed first
subpackages="$pkgname-lang"
-source="https://gitlab.gnome.org/World/podcasts/uploads/e07d05de378066ec528729e8897e1d1b/gnome-podcasts-$pkgver.tar.xz"
+source="https://gitlab.gnome.org/World/podcasts/uploads/7f5cb601b1eea22cc473077e8c0dcfad/gnome-podcasts-$pkgver.tar.xz
+ "
+
prepare() {
default_prepare
@@ -26,15 +41,17 @@ prepare() {
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- xvfb-run meson test --no-rebuild -v -C output
+ xvfb-run meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="3131089e033801b58edf28d07acbae0b0be10c12a42070a37d91f4886b7dec3603a48d7cd88a55fb71ef91431e494a58bebd8ab8bff6bc32147913c395ad43ba gnome-podcasts-0.4.9.tar.xz"
+sha512sums="
+59342a02314ed8062138c61c4d762756169307460d425c2f16110fcbfb3ea2dd33386ec968d7982f324c239180f515fc524ffd49f9d41e2b13691aa15134a737 gnome-podcasts-0.6.1.tar.xz
+"