aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-power-manager/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-power-manager/APKBUILD')
-rw-r--r--community/gnome-power-manager/APKBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/community/gnome-power-manager/APKBUILD b/community/gnome-power-manager/APKBUILD
index 57c15e580a5..59516fc655e 100644
--- a/community/gnome-power-manager/APKBUILD
+++ b/community/gnome-power-manager/APKBUILD
@@ -1,28 +1,36 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-power-manager
-pkgver=3.32.0
+pkgver=43.0
pkgrel=2
pkgdesc="GNOME power manager"
url="https://gitlab.gnome.org/GNOME/gnome-power-manager"
-# s390x and riscv64 blocked by polkit -> upower
-arch="all !s390x !riscv64"
+arch="all"
license="GPL-2.0-or-later"
-makedepends="intltool gobject-introspection-dev upower-dev gtk+3.0-dev meson"
+makedepends="
+ gobject-introspection-dev
+ gtk+3.0-dev
+ meson
+ upower-dev
+ "
subpackages="$pkgname-lang"
source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson \
+ -Db_lto=true \
+ . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="0ea11085dd015e30c1bdc6913000b63eabf7df76720f2d51d63b075f3b7bd2a610aaa484c53a4092d78d3c484ed8c4e81ec66603bdc6c132b0316113ec6a24a0 gnome-power-manager-3.32.0.tar.xz"
+sha512sums="
+d82c541821f09f6a3229b59ba29b1b77a0d8d11d0e10eab27edb9fc324955cc81f49395ff752bd1ecd2df456343ff8042466e91d1edf421521364a4779d67492 gnome-power-manager-43.0.tar.xz
+"