aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-screenshot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-screenshot/APKBUILD')
-rw-r--r--community/gnome-screenshot/APKBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/community/gnome-screenshot/APKBUILD b/community/gnome-screenshot/APKBUILD
index 031d3da27d6..c81714cafe4 100644
--- a/community/gnome-screenshot/APKBUILD
+++ b/community/gnome-screenshot/APKBUILD
@@ -1,16 +1,21 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-screenshot
pkgver=41.0
-pkgrel=0
+pkgrel=1
pkgdesc="Screenshot capture utility for GNOME"
url="https://gitlab.gnome.org/GNOME/gnome-screenshot"
-# s390x and riscv64 blocked by rust -> libhandy1
-arch="all !s390x !riscv64"
+arch="all"
license="GPL-2.0-or-later"
depends="desktop-file-utils"
-makedepends="meson libcanberra-dev glib-dev itstool appstream-glib-dev
- libhandy1-dev"
+makedepends="
+ appstream-glib-dev
+ glib-dev
+ itstool
+ libcanberra-dev
+ libhandy1-dev
+ meson
+ "
subpackages="$pkgname-doc $pkgname-lang"
source="https://download.gnome.org/sources/gnome-screenshot/${pkgver%.*}/gnome-screenshot-$pkgver.tar.xz
fix-build-with-meson-0.60.0.patch
@@ -18,11 +23,11 @@ source="https://download.gnome.org/sources/gnome-screenshot/${pkgver%.*}/gnome-s
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {