aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-session/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-session/APKBUILD')
-rw-r--r--community/gnome-session/APKBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/community/gnome-session/APKBUILD b/community/gnome-session/APKBUILD
index f3ca5c4e556..58446162a3e 100644
--- a/community/gnome-session/APKBUILD
+++ b/community/gnome-session/APKBUILD
@@ -1,19 +1,16 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=gnome-session
-pkgver=42.0
-pkgrel=1
+pkgver=45.0
+pkgrel=2
pkgdesc="GNOME session manager"
url="https://gitlab.gnome.org/GNOME/gnome-session"
-# s390x and riscv64 blocked by polkit -> upower
-arch="all !s390x !riscv64"
+arch="all"
license="GPL-2.0-or-later"
depends="
alsa-plugins-pulse
bash
dconf
- polkit
- pulseaudio-alsa
"
makedepends="
docbook-xml
@@ -27,26 +24,28 @@ makedepends="
libxml2-utils
libxslt
meson
- startup-notification-dev
upower-dev
xmlto
"
+replaces="gnome-shell"
options="!check" #no tests
subpackages="$pkgname-lang $pkgname-doc"
source="https://download.gnome.org/sources/gnome-session/${pkgver%%.*}/gnome-session-$pkgver.tar.xz
- 0001-revert-autostart-app-Strip-blacklisted-variables-fro.patch
- dont-require-systemd.patch"
+ gnome-session-bash-login.patch
+"
build() {
abuild-meson \
+ -Db_lto=true \
-Dsystemd_journal=true \
-Dsystemd_session=disable \
+ -Dsystemduserunitdir=/DELETEME \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -54,7 +53,6 @@ package() {
rm -rf "$pkgdir"/DELETEME
}
sha512sums="
-3d340700958b5800039e3009618709add2cdbaecb58344d9d2f93e4e761a737ef003091c380c68f95386dbb078b3d12f70732f0022611ab4a10e1c1eb988b4fa gnome-session-42.0.tar.xz
-3d61a847da175b780fce8b2646264836656e6cdc6294e0af6c667a64f30e6d837ef22ce54b3ac51c4f569a7e09844bdcd058417292ea014826256157fa7dbdc3 0001-revert-autostart-app-Strip-blacklisted-variables-fro.patch
-fc8d42503bffb7e35ea83cef41e6dc4b1c1e9fccbcd660e4cecf923486e24c3725566e644ba14a6e1dd02dd0620e959aa9b117ce52d9c708d2c83700daf68f83 dont-require-systemd.patch
+3eb3b4b9fcab2ec35bb61bac6257b254f142167250bbc1eb71d46aed350372f8942601c9d5ca5856e8686b53b70321f914cb55f1639daecfe6c61d84cb6d8aba gnome-session-45.0.tar.xz
+b606c906d2d1b8d34cff2c5a3653ef14c0897a49cecc74c604fddd7d95c4bb181f1027c2fc259d4e3df99278e5f66cd2cc088efbc5f9925d24eb73a7805b144b gnome-session-bash-login.patch
"