aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-shortwave/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-shortwave/APKBUILD')
-rw-r--r--community/gnome-shortwave/APKBUILD64
1 files changed, 48 insertions, 16 deletions
diff --git a/community/gnome-shortwave/APKBUILD b/community/gnome-shortwave/APKBUILD
index d36576b1e75..55cfb54da93 100644
--- a/community/gnome-shortwave/APKBUILD
+++ b/community/gnome-shortwave/APKBUILD
@@ -1,34 +1,66 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-shortwave
-pkgver=1.1.1
-pkgrel=0
+pkgver=3.2.0
+pkgrel=2
pkgdesc="Listen to internet radio"
url="https://gitlab.gnome.org/World/Shortwave"
-# s390x, mips64 and riscv64 blocked by rust/cargo
-arch="all !s390x !mips64 !riscv64"
+arch="all"
license="GPL-3.0-only"
-depends="gst-libav gst-plugins-base gst-plugins-bad gst-plugins-good gstreamer"
-makedepends="meson gettext cargo glib-dev gtk+3.0-dev libhandy-dev gstreamer-dev
- openssl1.1-compat-dev sqlite-dev gst-plugins-base-dev gst-plugins-bad-dev"
-checkdepends="appstream-glib desktop-file-utils"
-source="https://gitlab.gnome.org/World/Shortwave/uploads/df12909bb42afbff933e45da0f220eb4/shortwave-$pkgver.tar.xz"
+depends="
+ gst-libav
+ gst-plugins-bad
+ gst-plugins-good
+ "
+makedepends="
+ cargo
+ curl-dev
+ desktop-file-utils
+ glib-dev
+ gst-plugins-bad-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ gtk4.0-dev
+ libadwaita-dev
+ libshumate-dev
+ meson
+ openssl-dev>3
+ sqlite-dev
+ "
+checkdepends="
+ appstream-glib
+ xvfb-run
+ "
+source="https://gitlab.gnome.org/World/Shortwave/uploads/823870933d66693170571fdf09f2e355/shortwave-$pkgver.tar.xz
+ lfs64-libc.patch
+ lfs64-getrandom.patch
+ "
subpackages="$pkgname-lang"
builddir="$srcdir/shortwave-$pkgver"
+options="net"
+
+prepare() {
+ sed -i -e 's/\("files":{\)[^}]*/\1/' \
+ vendor/libc/.cargo-checksum.json \
+ vendor/getrandom/.cargo-checksum.json
+ default_prepare
+}
build() {
- abuild-meson \
- -Dprofile=default \
- . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ xvfb-run -a meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="365f28fcc610c22f177f1deb2dc57bad5547b7fffed0ffcb20c5b14fd961584315bb7129b4c5f27673ab79f549e57d00b644afac8a9002ba1daeb7eac7d588bb shortwave-1.1.1.tar.xz"
+sha512sums="
+c6ec78f65d32a98cc213fec2e3a6f872a2ea721e2d91358e7e5bd2c37e871515f3628db78cae84e388075ac7393faebce0598462012c6f53432858c13064a4b0 shortwave-3.2.0.tar.xz
+3ae8b2dbba84a4a4b8e10b58531e6b182028f246270fcf8b19f3b4758bbf0008bc17eeec1b1ad3d5aa9c5ae7a9aa9484c822ca33b73543d36c06592699c402cb lfs64-libc.patch
+7b097b4f4e074f8bc4983aae228d4b891121d96a9420b9240cfdea547dbc1d06134c806b59188e76a387da9aa098c1cc273233646fb7c109fcf369907f0ffcec lfs64-getrandom.patch
+"