aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-software-plugin-apk/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-software-plugin-apk/APKBUILD')
-rw-r--r--community/gnome-software-plugin-apk/APKBUILD33
1 files changed, 18 insertions, 15 deletions
diff --git a/community/gnome-software-plugin-apk/APKBUILD b/community/gnome-software-plugin-apk/APKBUILD
index fef81592ad1..b3063525627 100644
--- a/community/gnome-software-plugin-apk/APKBUILD
+++ b/community/gnome-software-plugin-apk/APKBUILD
@@ -1,32 +1,35 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Pablo Correa Gomez <ablocorrea@hotmail.com>
pkgname=gnome-software-plugin-apk
-pkgver=0.8.2
+pkgver=0.13.0
pkgrel=2
pkgdesc="APK plugin for GNOME Software"
url="https://github.com/Cogitri/gnome-software-plugin-apk"
arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # apk-polkit-rs
license="GPL-2.0-or-later"
-makedepends="meson gnome-software-dev gnome-software-static apk-polkit-rs-dev"
-options="!check" # no tests
+makedepends="meson gnome-software-dev apk-polkit-rs-dev appstream-dev"
+checkdepends="py3-dbusmock gnome-software"
+options="!check" # Tests will fail if gnome-software-plugin-apk is installed
+subpackages="$pkgname-dbg"
source="$pkgname-$pkgver.tar.gz::https://github.com/Cogitri/gnome-software-plugin-apk/archive/v$pkgver.tar.gz
- gnome-software-deps.patch"
-
-# We can't depend on gnome-software-plugin-apk directly in gnome-software
-# since that causes a circular dep:
-# gnome-software -> gnome-software-plugin-apk -> gnome-software-dev
-case "$CARCH" in
- x86_64|armv7|armhf|aarch64|x86|ppc64le) install_if="gnome-software" ;;
-esac
+ "
+# GNOME Software cannot depend on the plugin, due to the cylic dependency
+# on the checkdepends. One solution could be to merge the 2 aports.
+install_if="gnome-software"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="45e1f790dc7c6652b54c6f75b34aa485d33b3be2499cb997e3c8c6417bb403669d99d67cc91be71caa1d5ce537672bf25a75b517882168bee89c0c540fcdb651 gnome-software-plugin-apk-0.8.2.tar.gz
-15894937b543f353803700e8c1eaaf2965c9de2e8ada439f2204834f9ba92471a8ca476d3a380e57e2966062514f1b6278f76819831d9fa2d4852ecbefa2a47c gnome-software-deps.patch"
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
+}
+
+sha512sums="
+7863a3872517ea4acc6f5722e1dd3a90a80900639c06e2367b1127a4c456f387c717b6d75000c1b277f374433d31f61961f25193dd54ee8b0dea01c337a832e2 gnome-software-plugin-apk-0.13.0.tar.gz
+"