aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-sound-recorder/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-sound-recorder/APKBUILD')
-rw-r--r--community/gnome-sound-recorder/APKBUILD27
1 files changed, 18 insertions, 9 deletions
diff --git a/community/gnome-sound-recorder/APKBUILD b/community/gnome-sound-recorder/APKBUILD
index 752bc37e687..268423939f6 100644
--- a/community/gnome-sound-recorder/APKBUILD
+++ b/community/gnome-sound-recorder/APKBUILD
@@ -1,30 +1,39 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-sound-recorder
-pkgver=40.0
+pkgver=42.0
pkgrel=1
pkgdesc="simple and modern sound recorder"
url="https://wiki.gnome.org/Apps/SoundRecorder"
-arch="noarch !s390x !mips !mips64 !riscv64" # limited by gjs
+arch="noarch !armhf !s390x !riscv64" # limited by gjs
license="GPL-2.0-or-later"
-makedepends="gjs-dev glib-dev gtk+3.0-dev gobject-introspection-dev meson
- gst-plugins-bad-dev libhandy1-dev"
-depends="gjs gtk+3.0 glib gst-plugins-good libhandy1"
+makedepends="
+ gjs-dev
+ glib-dev
+ gobject-introspection-dev
+ gst-plugins-bad-dev
+ gtk4.0-dev
+ libadwaita-dev
+ meson
+ "
+depends="gjs gtk4.0 glib gst-plugins-good libadwaita"
checkdepends="appstream-glib desktop-file-utils"
subpackages="$pkgname-lang"
source="https://download.gnome.org/sources/gnome-sound-recorder/${pkgver%.*}/gnome-sound-recorder-$pkgver.tar.xz"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="28de1dbb9251c834513be55c3f4107cd014d74e634e383e6feb3b9430ff562e19d29e9abcd566b0fc0ed1ec3841add0f694b47c51fe91a3b4ba33b9f43a0d617 gnome-sound-recorder-40.0.tar.xz"
+sha512sums="
+53fe2fe0646c5055cedc1c62cf87176dca52bf3d9452d83bcc849d9946179afbef826f08ff65a97ede7a0d14ade4da0755b2ef3780460d5a80f8f9e6c85fcfbd gnome-sound-recorder-42.0.tar.xz
+"