aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-sound-recorder/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-sound-recorder/APKBUILD')
-rw-r--r--community/gnome-sound-recorder/APKBUILD40
1 files changed, 23 insertions, 17 deletions
diff --git a/community/gnome-sound-recorder/APKBUILD b/community/gnome-sound-recorder/APKBUILD
index 9ba67989127..268423939f6 100644
--- a/community/gnome-sound-recorder/APKBUILD
+++ b/community/gnome-sound-recorder/APKBUILD
@@ -1,33 +1,39 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-sound-recorder
-pkgver=3.34.0
-pkgrel=0
-pkgdesc="A simple and modern sound recorder"
+pkgver=42.0
+pkgrel=1
+pkgdesc="simple and modern sound recorder"
url="https://wiki.gnome.org/Apps/SoundRecorder"
-arch="all !s390x" # Dependency gjs-dev is not available on s390x
+arch="noarch !armhf !s390x !riscv64" # limited by gjs
license="GPL-2.0-or-later"
-makedepends="gjs-dev glib-dev gtk+3.0-dev gobject-introspection-dev meson"
+makedepends="
+ gjs-dev
+ glib-dev
+ gobject-introspection-dev
+ gst-plugins-bad-dev
+ gtk4.0-dev
+ libadwaita-dev
+ meson
+ "
+depends="gjs gtk4.0 glib gst-plugins-good libadwaita"
+checkdepends="appstream-glib desktop-file-utils"
subpackages="$pkgname-lang"
source="https://download.gnome.org/sources/gnome-sound-recorder/${pkgver%.*}/gnome-sound-recorder-$pkgver.tar.xz"
build() {
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --buildtype=release \
- . output
- ninja -C output
+ abuild-meson . output
+ meson compile -C output
}
check() {
- ninja -C output test
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="cb28f1f93f78cae5cc98750f937f60abb326065cdbbb1ee48146daceb9e34f03bc9bf4d78b7a149e579654673b9879fb249fd5a370a19764f01961c565b901ee gnome-sound-recorder-3.34.0.tar.xz"
+sha512sums="
+53fe2fe0646c5055cedc1c62cf87176dca52bf3d9452d83bcc849d9946179afbef826f08ff65a97ede7a0d14ade4da0755b2ef3780460d5a80f8f9e6c85fcfbd gnome-sound-recorder-42.0.tar.xz
+"