aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-system-monitor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-system-monitor/APKBUILD')
-rw-r--r--community/gnome-system-monitor/APKBUILD34
1 files changed, 24 insertions, 10 deletions
diff --git a/community/gnome-system-monitor/APKBUILD b/community/gnome-system-monitor/APKBUILD
index bbff9cd1f6b..587b20ecdde 100644
--- a/community/gnome-system-monitor/APKBUILD
+++ b/community/gnome-system-monitor/APKBUILD
@@ -1,28 +1,42 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=gnome-system-monitor
-pkgver=40.1
+pkgver=46.0
pkgrel=0
pkgdesc="GNOME system monitor"
url="https://www.gnome.org/"
-arch="all !s390x !mips !mips64 !riscv64" # limited by librsvg -> rust
+arch="all"
license="GPL-2.0-or-later"
-makedepends="gnome-desktop-dev libgtop-dev gtkmm3-dev
- libxml2-dev librsvg-dev itstool libxml2-utils libxslt
- meson polkit-dev libhandy1-dev"
+makedepends="
+ glibmm2.68-dev
+ gnome-desktop-dev
+ gtkmm4-dev
+ itstool
+ libadwaita-dev
+ libgtop-dev
+ librsvg-dev
+ libxml2-dev
+ libxml2-utils
+ libxslt
+ meson
+ polkit-dev
+ "
checkdepends="appstream-glib desktop-file-utils"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.gnome.org/sources/gnome-system-monitor/${pkgver%.*}/gnome-system-monitor-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/gnome-system-monitor/${pkgver%%.*}/gnome-system-monitor-$pkgver.tar.xz"
build() {
+ # localtime_r
+ CFLAGS="$CFLAGS -D_BSD_SOURCE" \
abuild-meson \
+ -Db_lto=true \
-Dsystemd=false \
output .
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -30,5 +44,5 @@ package() {
}
sha512sums="
-a6c870ae4e58c5fabdc87c290e10326b051398b3408f7ff159c854eef5c7940371e83766f37c6a713631d49ee5ee7b2670f441a462e2453fa849cba2f3255be4 gnome-system-monitor-40.1.tar.xz
+2bba46bf5f03d4b8ad6e45e42b2d7ce21859037a1bd386ea17276d10c0eba506c718ab5bc4c203823cabd830bdaac3d61753dbb3b364eaf4dfea0031fea0ac27 gnome-system-monitor-46.0.tar.xz
"