aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-system-monitor/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-system-monitor/APKBUILD')
-rw-r--r--community/gnome-system-monitor/APKBUILD45
1 files changed, 28 insertions, 17 deletions
diff --git a/community/gnome-system-monitor/APKBUILD b/community/gnome-system-monitor/APKBUILD
index 4032b261b1a..ebfed04c2ef 100644
--- a/community/gnome-system-monitor/APKBUILD
+++ b/community/gnome-system-monitor/APKBUILD
@@ -1,37 +1,48 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=gnome-system-monitor
-pkgver=3.36.0
+pkgver=46.0
pkgrel=1
pkgdesc="GNOME system monitor"
url="https://www.gnome.org/"
-arch="all !s390x !mips !mips64" # librsvg
+arch="all"
license="GPL-2.0-or-later"
-makedepends="gnome-desktop-dev libgtop-dev gtkmm3-dev
- libxml2-dev librsvg-dev itstool libxml2-utils libxslt
- meson polkit-dev"
+makedepends="
+ glibmm2.68-dev
+ gnome-desktop-dev
+ gtkmm4-dev
+ itstool
+ libadwaita-dev
+ libgtop-dev
+ librsvg-dev
+ libxml2-dev
+ libxml2-utils
+ libxslt
+ meson
+ polkit-dev
+ "
checkdepends="appstream-glib desktop-file-utils"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.gnome.org/sources/gnome-system-monitor/${pkgver%.*}/gnome-system-monitor-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/gnome-system-monitor/${pkgver%%.*}/gnome-system-monitor-$pkgver.tar.xz"
build() {
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --datadir=/usr/share \
- --buildtype=plain \
+ # localtime_r
+ CFLAGS="$CFLAGS -D_BSD_SOURCE" \
+ abuild-meson \
+ -Db_lto=true \
-Dsystemd=false \
output .
- ninja -C output
+ meson compile -C output
}
check() {
- ninja -C output test
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="b012f7192e7a8f0dc2c61a0656b92c384c424a45ea9b80261f1acf8c99669f009809721cf34f481b154143c4d5f498e5f28b698e0e59e5edba9957014dccf425 gnome-system-monitor-3.36.0.tar.xz"
+sha512sums="
+2bba46bf5f03d4b8ad6e45e42b2d7ce21859037a1bd386ea17276d10c0eba506c718ab5bc4c203823cabd830bdaac3d61753dbb3b364eaf4dfea0031fea0ac27 gnome-system-monitor-46.0.tar.xz
+"