aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-terminal/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-terminal/APKBUILD')
-rw-r--r--community/gnome-terminal/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/community/gnome-terminal/APKBUILD b/community/gnome-terminal/APKBUILD
index 0078306a597..b75c8331319 100644
--- a/community/gnome-terminal/APKBUILD
+++ b/community/gnome-terminal/APKBUILD
@@ -1,12 +1,12 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-terminal
-pkgver=3.44.0
-pkgrel=1
+pkgver=3.52.0
+pkgrel=0
pkgdesc="GNOME terminal emulator application"
url="https://wiki.gnome.org/Apps/Terminal"
-# s390x and riscv64 blocked by polkit -> gnome-shell
-arch="all !s390x !armhf !ppc64le !riscv64"
+# gnome-shell
+arch="all !armhf !s390x !riscv64"
license="GPL-2.0-or-later AND GFDL-1.3-only"
depends="
dbus
@@ -20,32 +20,34 @@ makedepends="
glib-dev
gnome-shell
gsettings-desktop-schemas-dev
- intltool
itstool
+ libhandy1-dev
meson
nautilus-dev
pcre2-dev
vte3-dev
"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://download.gnome.org/sources/gnome-terminal/${pkgver%.*}/gnome-terminal-$pkgver.tar.xz
+source="https://gitlab.gnome.org/GNOME/gnome-terminal/-/archive/$pkgver/gnome-terminal-$pkgver.tar.gz
fix-W_EXITCODE.patch
"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
+
+ rm -rf "$pkgdir"/usr/lib/systemd
}
sha512sums="
-0cf039c0aa364a9ac63d9f24d466506a919cf733f2ee8dc1c6f42459e6c742bad678f7ad7cec3721e9512b8f414dc4c4c1f29057c73e5e4a870a04d6bcd98ed6 gnome-terminal-3.44.0.tar.xz
+cc7bf7e603308896187f6931504903953d4a2f0a634f89ff0a90ce31834b582dba831809398b6d457e785a180f21a16616fd708369de394f19d227f1c2b0b08f gnome-terminal-3.52.0.tar.gz
3bbc0e9dbbbfd4a3263b5d195a78df9cc70d13ae02d3a2981886001e79d92c2bfe4962954efba8fbab69f23e1778d5fbe3436f494b70e196ecedb02bf9d95400 fix-W_EXITCODE.patch
"