aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-weather/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gnome-weather/APKBUILD')
-rw-r--r--community/gnome-weather/APKBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/community/gnome-weather/APKBUILD b/community/gnome-weather/APKBUILD
index 38d279de140..e9ac830f5c5 100644
--- a/community/gnome-weather/APKBUILD
+++ b/community/gnome-weather/APKBUILD
@@ -1,13 +1,21 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=gnome-weather
-pkgver=42.0
+pkgver=46.0
pkgrel=0
pkgdesc="GNOME Weather application"
url="https://wiki.gnome.org/Apps/Weather"
-# s390x and riscv64 blocked by gjs
-arch="noarch !s390x !riscv64"
+# armhf and s390x and riscv64 blocked by gjs
+arch="noarch !armhf !s390x !riscv64"
license="GPL-2.0-only"
+depends="
+ geoclue
+ gjs
+ gobject-introspection
+ gtk4.0
+ libadwaita
+ libgweather4
+ "
makedepends="
geoclue-dev
gjs-dev
@@ -24,11 +32,11 @@ source="https://download.gnome.org/sources/gnome-weather/${pkgver%.*}/gnome-weat
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -36,5 +44,5 @@ package() {
}
sha512sums="
-10471a32adc148fad393e03098396a3cfccc75d1cd18985cdd2c287927213aeb493f2878ea986e1d3a3af4b1d3f439afcdb96833d849bbd5fbe7aebb1d1992e6 gnome-weather-42.0.tar.xz
+b180b231359e7b1cfa593b9a536d77520d6183aa752a8900bb27a290bc5f6f9676da132897e51e2810baca57196c9328a8cbbbb172068f52409076e39ba87a8b gnome-weather-46.0.tar.xz
"